Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

написать программу на языке паскаль,которая считывает с клавиатуры строку S, состоящую из цифр. В заданном строкой S натуральном N-разрядном

10-11 класс

числе упорядочить цифры так, чтобы получить наибольшее число, записанное теми же цифрами. Строка S не пустая и содержит не более 200 символов. Строка S состоит только из цифр.

ученик006 10 нояб. 2015 г., 7:12:59 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Skleminatatian
10 нояб. 2015 г., 8:17:14 (8 лет назад)

s, a, d:string;
i,  n, j, b:integer;
c:array[1..200] of integer;
begin
readln(s);
readln(n);
a:=copy(s, 1, n);
for i:=1 to n do
val(a[i], c[i]);
for i:=1 to n do
for j:=1 to n do
if c[i]<c[j] then begin
b:=c[i]; c[i]:=c[j]; c[j]:=b; end;
for i:=1 to n do
str(c[i], d[i]);
s:=d;
writeln(s);
readln;
end.

Ответить

Другие вопросы из категории

Ввести двумерный массив А(3х4) . Определить в нём количество

элементов, квадрат которых больше 25

помогите решить!

Сколько различных решений имеет система
уравнений

Читайте также

написать программу на Assembler

добрый вечер, всем. помогите, пожалуйста, написать программу на Ассемблере.

задание:
Создать программу на языке Ассемблер, что позволяет организовать вычисления над элементами массивов

Объединить два массива 8-битных целых чисел со знаком. Сначала элементы второго затем первого.

заранее огромное спасибо всем!

3. Не используя функцию возведения в квадрат, напишите на языке Паскаль наиболее короткие алгоритмы вычисления а) y=x¹° б)y=x¹⁵ или а) y=x^10

б)y=x^15

Постараться использовать минимальное количество дополнительных переменных.

4. Запишите на языке Паскаль программу циклического обмена значениями трёх переменных a,b,c. Схема циклического обмена: a ← b ← c. Например, если до обмена было: a=1, b=2, c=3, то после обмена должно стать: a=2, b=3, c=1.

1)Вычислить значения функции y=4*x^3-2*x^2+5 для x, изменяющегося от -3 до 1 с шагом 0,1 на языке ПАСКАЛЬ!!СРОЧНОО ЗАВТРА ЭКЗАМЕН РЕБЯЯТКИ!

2)Найти количество всех нечетных чисел на интервале от 11 до 20
3)Найти сумму целых положительных четных чисел на интервале от 1 до 100
4)Найти сумму ряда,общий член которого равен А(х)=1/(3*N-2)*(3*N+1)
5)Дано произвольное число n≤100.Определить количество цифр в числе
ОЧЕНЬ НУЖНО!!НА ЯЗЫКЕ ПАСКАЛЬ!ВЫРУЧАЙТЕ!

Написать программу на языке Паскаль для вычисления значений функции y (см. для своего варианта) на интервале [a,b] с шагом h. Значения a,b и h ввести с

клавиатуры. На экран вывести результат вычислений в виде таблицы. 1 Блок-схема алгоритма программы, выполненная с использованием графических средств редактора WORD; 2 Текст программы; 3 Результаты выполнения (копия экрана). (3x+2)^2- sqrt3x/(3x)^2 a 5;b 7; h 0,1



Вы находитесь на странице вопроса "написать программу на языке паскаль,которая считывает с клавиатуры строку S, состоящую из цифр. В заданном строкой S натуральном N-разрядном", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.