Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

РЕШИТЕ В ПАСКАЛЕ Написать по действиям решения примера: Y=Sqrt (5x-4/7*x^2) + x^2/2

10-11 класс

Max86rus 15 нояб. 2016 г., 11:10:17 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Konalla
15 нояб. 2016 г., 14:00:06 (7 лет назад)

var x, y: real;
begin
  readln(x); // просим x с клавиатуры
  y := sqrt(5*x-(4/7)*sqr(x)) + sqr(x)/2; // вычисляем y
  writeln(y:0:5); // выводим y c точностью 5 знаков
end.

Ответить

Другие вопросы из категории

1. Закодируйте слово COMPUTER, используя коды ITA2 и ASCII.

2. Как прочитается фраза ШАЙБУ-ШАЙБУ! , закодированная с использованием CP1251, если кодирование просиходит по коду KOI8-R.

Ско­рость пе­ре­да­чи дан­ных через мо­дем­ное со­еди­не­ние равна 4096 бит/с. Пе­ре­да­ча тек­сто­во­го файла через это со­еди­не­ние за­ня­ла 10

с. Опре­де­ли­те, сколь­ко сим­во­лов со­дер­жал пе­ре­дан­ный текст, если из­вест­но, что он был пред­став­лен в 16-бит­ной ко­ди­ров­ке Unicode.

Читайте также

Помогите решить задачуна паскале.

Возможность отправлять закодированные сообщения во время Второй мировой войны была достаточно важной для союзников. Сообщения всегда отправлялись после их кодирования при помощи известного пароля. Иметь фиксированный пароль было небезопасно, поэтому возникла необходимость часто изменять его. Однако следовало разработать механизм отправления нового пароля. У одного из математиков, работавших в криптографической команде, возникла умная идея - отправить пароль, скрытый в самом сообщении. Интересным моментом было то, что получателю сообщения достаточно было знать только размер пароля, а потом найти его в полученном тексте.

Пароль размера n можно найти поиском в тексте наиболее часто встречаемой подстроки из n символов. После нахождения пароля все подстроки совпадающие с ним, удаляются из текста. Теперь пароль можно использовать для расшифровки сообщения.

Однако Ваша задача будет упрощена. Вам достаточно написать программу, которая по заданному размеру пароля и закодированному сообщению найдет пароль в соответствии с описанным выше алгоритмом.

Рассмотрим пример, в котором размер пароля равен трем (n = 3), а текст сообщения имеет вид baababacb. Паролем будет aba, потому что размер этой подстроки 3, она появляется чаще всего во всем тексте (дважды), а остальные шесть различных подстрок появляются только один раз (baa, aab, bab, bac, acb).

Технические условия

Входные данные

Состоит из нескольких тестов. Каждый тест представляет собой одну строку, в которой находится длина пароля n (0 < n ≤ 10) и закодированное сообщение. Сообщение содержит только прописные буквы латинского алфавита, его длина не более 106 и не меньше n.

Выходные данные

Для каждого теста в отдельной строке следует вывести искомый пароль. Если существует несколько паролей, удовлетворяющих задаче, то вывести лексикографически наименьший.

Написать программу вНаписать программу в паскале.Проверить правильность решения примера (вида 2+3=5):

1) Пример содержит два многозначных числа (123+45=168)
2) Содержит любое количество многозначных чисел (123+45+23+1+1678 + ... = ...)



Вы находитесь на странице вопроса "РЕШИТЕ В ПАСКАЛЕ Написать по действиям решения примера: Y=Sqrt (5x-4/7*x^2) + x^2/2", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.