Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Ребят помоги пожалуйста решить задачку на C++. Транспонировать матрицу A размером M×N. Результатом транспонирования матрицы A размером M×N

5-9 класс

является матрица B размером N×M полученная из исходной матрицы заменой строк на столбцы

Nikysay2002 24 нояб. 2016 г., 12:30:37 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Викулёк26
24 нояб. 2016 г., 14:31:24 (7 лет назад)

#include<iostream>
#include<ctime>

using namespace std;

int main(){
srand(time(NULL));
int **arr, N, M;
cout << "N : ";
cin >> N;
cout << "M : ";
cin >> M;
arr = new int *[N];
for(int i = 0; i < M ; i++)
arr[i] = new int [M];

for(int i = 0; i < N ; i++)
for(int j = 0; j < M ; j++)
arr[i][j] = rand() % 150;
cout << "your array : " << endl;
for(int i = 0; i < N ; i++){
for(int j = 0; j < M ; j++)
cout << arr[i][j] << "\t";
cout << endl;
}
cout << "your NEW array : " << endl;
for(int i = 0; i < N ; i++){
for(int j = 0; j < M ; j++)
cout << arr[j][i] << "\t";
cout << endl;
}
cout << endl;
}

+ 0 -
Анько3
24 нояб. 2016 г., 16:52:20 (7 лет назад)

int **arr, N, M;
cout << "N : ";
cin >> N;
cout << "M : ";
cin >> M;
arr = new int *[N];
for(int i = 0; i < M ; i++)
arr[i] = new int [M];

for(int i = 0; i < N ; i++)
for(int j = 0; j < M ; j++)
arr[i][j] = rand() % 150;
cout << "your array : " << endl;
for(int i = 0; i < N ; i++){
for(int j = 0; j < M ; j++)
cout << arr[i][j] << "\t";
cout << endl;
}
cout << "your NEW array : " << endl;
for(int i = 0; i < N ; i++){
for(int j = 0; j < M ; j++)
cout << arr[j][i] << "\t";
cout << endl;

Ответить

Другие вопросы из категории

что может рассматриваться в качестве фрагмента текста?

1)символ
2)слово
3)строка
4)предложение
5)абзац
6)документ
7)последовательность символов

Читайте также

Помогите пожалуйсто решить прошу очень срочно!!!!

1. Чему равны значения переменных r, a, d?
a:=5; b:=20; c:=-7;
d:=2.5;
r := a+(4*b+c)*d;
a:= a+4;
d:=a*7;

2. В пяти тестовых опросах мальчик получил оценки. Составьте программу, которая определит среднее значение оценок, полученных мальчиком в пяти опросах.

3*. Задача. «Покупка в магазине»
Человек делает в магазине покупки. Определите сколько денег у него останется после покупки в магазине перчаток стоимостью А руб., портфеля стоимостью B руб. и галстука стоимостью D руб. Все исходные данные задаются с клавиатуры.

Исходные данные.
a — стоимость перчаток;
b — стоимость портфеля;
d — стоимость галстука;
dengi — количество денег у человека.
Все эти переменные будут вещественного типа.
Результат.
ostatok — количество денег, которое останется у человек (вещественный тип).
Метод решения.
ostatok = dengi – a – b – d
Написать программу, реализующую данную задачу
Помогите пожалуйсто решить очень срочно!!!!!!

Люди Люди Люди если вы читаете это сообщение значит вы просто обязаны помочь! пожалуйста если у вас есть паскаль помогите пожалуйста решить первое и

второе задание ну или хотя бы только первое .Это вопрос жизни и смерти помогите пожалуйста P.S задание во вложениях.заранее спасибо и знайте если вы поможете значит вы самый добрый и отзывчивый человечек!)

Помогите пожалуйста решить задачу на С++

Заполнить массив по следующему принципу:
31 25 19 13 7 1
32 26 20 14 8 2
33 27 21 15 9 3
34 28 22 16 10 4
35 29 23 17 11 5
36 30 24 18 12 6

Помогите, пожалуйста, решить задачу на языке программирования в Turbo Pascal: 1.Дан массив целых чисел, состоящий из 10 элементов.Заполнить его

с клавиатуры. Найти:
-Удвоенную сумму положительных элементов;
-вывести индексы тех элементов, значения которых больше значения предыдущего элемента(начиная со второго).

2.Определить,есть ли 2 пары соседних элементов с одинаковыми знаками.

Помогите, пожалуйста, решить задачи на языке программирования в Turbo Pascal. 1) Определить максимальн

ый элемент квадратной матрицы, расположенный в правой части, ограниченной диагоналями, включая диагональные элементы.

2) Дана таблица с оценками 12 учащихся по девяти предметам. Определить номер предмета, содержащий максимальный средний балл.



Вы находитесь на странице вопроса "Ребят помоги пожалуйста решить задачку на C++. Транспонировать матрицу A размером M×N. Результатом транспонирования матрицы A размером M×N", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.