Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 975 ответов!

Определить, равна ли сумма двух первых цифр заданного четырехзначного числа сумме двух его последних цифр

10-11 класс

Lenauzunova 15 апр. 2013 г., 13:25:36 (11 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Finny
15 апр. 2013 г., 13:58:00 (11 лет назад)

var
str:string;
begin
readln(str);

if ((ord(str[1])+ord(str[2])) = (ord(str[3]) + ord(str[4]))) then write('Сумма равна')
  else write('Сумма неравна');

end.

+ 0 -
Inuray2003
15 апр. 2013 г., 16:07:21 (11 лет назад)

uses crt;
var x:integer;
begin
     write('Введи число:');
     readln(x);
     if (x>=1000) and (x<=9999) then
          if (x div 1000)+(x div 100 mod 10)=(x mod 10)+(x mod 100 div 10) then
             writeln('yes')
          else writeln('no')
     else writeln('error');
end.

Ответить

Другие вопросы из категории

Помогите пожалуйста решить:

1)на экране монитора необходимо получить 32 оттенка серого цвета. Какая должна быть глубина цвета?
2) 64-цветный рисунок содержит 2 Кбайт информации. Из скольких точек он состоит?

помогите!!!

подчеркнутая буква в строке меню означает

История 3.

А теперь представьте, что вы с ценным товаром – спичками – прилетели на планету Кин-дза-дза. У вас 10 000 упаковок по 20 рублей за упаковку. У них так шестнадцатеричная система счисления. Они, не разобравшись все раскупают по 20 своих кин-дза-дзовских рублей, которые вы потом спокойно меняете на свои десятичные. Какова же неожиданная прибыль?

Читайте также

Помогите с тестами по информатике!!! А1. Определите значение целочисленных переменных a и b после выполнения фрагмента программы:

a := 3 + 3*4;

b := (a div 10) + 4;

a := (b mod 10) + 2;

b:= a + b;

a:= a mod 2 + b div 3;

1) a=4, b=14;

2) a= 24, b= 6;

3) a=5, b=12;

4) a=8, b=12.

А2. Для какого из указанных значений числа X истинно высказывание

((X < 5)→(X < 3)) Ù ((X < 2)→(X < 1))

1) 1

2) 2

3) 3

4) 4

А3. Укажите, какое логическое выражение равносильно выражению ¬(A Ú ¬B Ú C) ?

1) ¬A Ú B Ú ¬C

2) A Ù ¬B Ù C

3) ¬A Ú ¬B Ú ¬C

4) ¬A Ù B Ù ¬C

X

Y

Z

F

1

1

1

1

1

1

0

1

1

0

1

1

А4. Символом F обозначено одно из указанных ниже логических выражений от трех аргументов: X, Y, Z. Дан фрагмент таблицы истинности выражения F (см. таблицу справа).

Какое выражение соответствует F?

1) X Ú ¬Y Ú Z

2) X Ù Y Ù Z

3) X Ù Y Ù ¬Z

4) ¬X Ú Y Ú ¬Z

А5. Что будет выведено на печать в результате выполнения следующих операторов:

a := 5; b := 10;

write( 'сумма двух чисел ' ); write( 'a+b' );

write( ' = ', a+b );

1) сумма двух чисел 5+10 = 15

2) сумма двух чисел a+b = 15

3) сумма двух чисел 5+10 = a+b

4) сумма двух чисел a+b = 5+10

5) ни один из ответов 1-4 не верен

А6. Чему было равно значение переменной a, если после выполнения операций

b := sqrt( sqr(a+1) );

c := -b;

a := 1 + 2 / (c-b);

она стала равна 0 ?

1) 2

2) 0

3) –1

4) любое вещ. число, не равное -1

5) ни один из ответов 1-4 не верен

А7. Чему будет равно значение А после выполнения цикла

а:=1024;

While a>0 do

a:=a / 2;

1) 0

2) 1

3) зациклится

4) 512

5) ни один из ответов 1-4 не верен

A8. Сколько раз выполнится тело цикла?

A:=32;

While A>2 do

Begin A:=A / 2; writeln(‘A’); end;

1) 8

2) 6

3) 5

4) 4

5) 3

1. Составьте алгоритм вычисления суммы квадратов цифр,заданного трехзначного числа.

2.Составить алгоритм вычисления разности кубов цифр, заданного восьмизначного числа.
3. Для заданного действительного числа К вычислить значение произведения
(99/k^3-98)*(97/k^3+96)*(95/k^3-94)*...*(3/k^3+2)

4 задачи: ввести натуральное число и определить, верно ли, что сумма цифр равна 10 (через repeat и until)//// ввести натуральное

число и определить, какие цифры встречаются несколько раз (через repeat и until)///

ввести целое число и найти сумму его цифр (через while)

ввести целое число и определить , верно ли, что в его записи есть две одинаковые цифры(через while)

всё через паскаль абс

Последовательность чисел Фибоначчи образуется так: первый и второй члены последовательности равны единице, каждый следующий член равен сумме двух

предыдущих. (1,1,2,3,5,13...).Дано натуральное число n. n>=3. а)Найти k-й член этой последовательности; б)Для заданного n определить верно ли, что сумма первых n-членов последовательности есть четное число. Помогите, нужно составить программу для решения данных задач!



Вы находитесь на странице вопроса "Определить, равна ли сумма двух первых цифр заданного четырехзначного числа сумме двух его последних цифр", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.