Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

1.Вычислить сумму ряда s= cos(x)+cos(x)*cos(x)+...+cos(x)*cos(x)*...*cos(x), для x и n введенных с клавиатуры.

10-11 класс

Sasha270208 23 сент. 2013 г., 6:28:08 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Kavrolin
23 сент. 2013 г., 9:00:31 (10 лет назад)

Var n, i: Integer;
    x, sum, temp, cosx: Double;
begin
  ReadLn(x, n);
  sum:=0;
  cosx:=cos(x);
  temp:=1;
  for i:=1 to n do begin
    temp:=temp*cosx;
    sum:=sum+temp;
  end;
  WriteLn(sum);
end.

+ 0 -
Michlen
23 сент. 2013 г., 11:59:01 (10 лет назад)

Var x, n, i, j, r: Integer;
    sum, temp: Double;
begin
  ReadLn(x, n);
  sum:=0;
  r:=cos(x);
  for i:=1 to n do begin
    temp:=r;
    for j:=1 to i do temp:=temp*temp;
    sum:=sum+temp;
  end;
  WriteLn(sum);
end.

Ответить

Другие вопросы из категории

5. Системы счисления.

a. Переведите данное число из десятичной системы счисления в двоичную, восьмеричную и шестнадцатеричную системы счисления: 114,22510
b. Переведите данные числа в десятичную систему счисления:
100111100,11012
1234,58
2B3,F416
c. Сложите числа:
1001100111,112 + 100001101,1012
272,348 + 1567,28
65,216 + ЗСА,716
d. Выполните вычитание:
1110110110,00112 – 11111110,012
1360,148 – 1216,48
ЗЗВ,616 – 11В,416

e. Выполните умножение
111,1012*1012
124,38*378
1А416*F316
6. В системе счисления с некоторым основанием десятичное число 49 записывается в виде 100. Укажите это основание.

Вычислите среднее арифметическое число положительных элементов массива A(N1), B(N2), C(N3)

Помогите пожалуйста очень срочно надо))), заранее спасибо)))

Читайте также

Задание 2 Тема: Ряды (циклы, итерации). Операторы DO используются для организации цикл

ических расчетов.

Цикл - это последовательность операторов, которая может автоматически выполняться более одного раза. Если количество повторов известно заранее (или может быть однозначно вычислено), используется оператор Цикл_с_параметром (DO «UNTIL»). Если количество повторов неизвестно, применяется оператор Цикл_с_Пред_условием (DO «WHILE»).

Вычислить сумму ряда:

a) с заданной точностью ξ и вывести количество итераций;

b) для 20-ти членов ряда.

Σ = 1/(1*3) + 1/(3*5) + 1/(5*7) + … ξ=0.0001 Ответ: 0.500

Для заданного положительного e и заданного x вычислить сумму ряда с точностью e. Суммирование ряда завершается, если модуль очередного слагаемого меньше

e. Определив тип общего члена ряда, и организовав вычисление его суммы со структурой вложенных циклов, получить таблицу, состоящую из переменных X, Y, S, при |X|<1.

1) Написать программу для вычисления суммы цифр пятизначного числа , введенного с клавиатура

2) Заданы действительные числа a , b , c и d . Написать программу нахождения полусуммы наименьшего и наибольшего из них.
3) Написать программу для вычисления суммы цифр числа , введенного с клавиатуры

Помогите прошу



Вы находитесь на странице вопроса "1.Вычислить сумму ряда s= cos(x)+cos(x)*cos(x)+...+cos(x)*cos(x)*...*cos(x), для x и n введенных с клавиатуры.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.