Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 975 ответов!

дана квадратная матрица действительных чисел.Найти сумму модулей элементов , расположенных выше главной диагонали.

10-11 класс

Dmitrii19952011 27 марта 2014 г., 3:22:18 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Kisaavesta
27 марта 2014 г., 5:54:16 (10 лет назад)

program gt;
var A: array[1..1000,1..1000] of real;
n,m,i,j:integer;
s: real;
begin
read(n,m);    //размеры массива
s:=0;
for i:=1 to N do
for j:=1 to M do
begin
read(a[i,j]);
if(j>i)then s:=s+abs(a[i,j]);
end;
writeln(s);
end.

Ответить

Другие вопросы из категории

Плиз помогите с информатикой( в башке заело) ( здесь нужно использовать циклы for while или repeat);заранее спасибо)

1)Натуральное число n называется простым если оно делится только на 1 и на само себя.по соглашению 1 не считают простым числом. Проверить является ли n простым числом

2)Найдите и выведите на экран все трехзначные числа кратные 3, сумма цифр которых больше суммы цифр частного от деления их на 3

Помогите сделать блок-схему:

Вводятся a,b,c. Найти количество положительных чисел.

Два текста содержат одинаковое количество символов. Первый текст составлен в алфавите мощностью 16 символов, а второй текст - в алфавите из 256

символов. Во сколько раз количество информации во втором тексте больше, чем в первом?

Читайте также

Элемент матрицы называется локальным минимумом, если

он строго меньше всех имеющихся у него соседей. Подсчитать количество локальных
минимумов заданной матрицы размером 10 на 10.

Найти сумму модулей элементов, расположенных выше
главной диагонали.
на языке С

1.Дан целочисленный массив X(N). Найти сумму четных элементов массива .Если эта сумма больше заданного числа Z , то у элементов , расположенных на

нечетных местах , сменить знак на противоположный ,иначе выдать соответствующее сообщение.

2.Дан массив X(N,M) . Среди четных столбцов массива найти сумму положительных элементов

3.Найти произведение элементов каждого столбца массива принадлежащих промежутку [2,6] . Из полученных значений сформировать одномерный массив.

Помогите, пожалуйста! Есть код программы в QBasic, нужно продолжить блок-схему.

Дана квадратная матрица. Найти минимальное значение среди элементов, расположенных выше главной диагонали.

Составить программу на языке паскаль

задание: дана матрица А(N, N). Составить программу подсчета количества положительных элементов, расположенных выше главной диагонали



Вы находитесь на странице вопроса "дана квадратная матрица действительных чисел.Найти сумму модулей элементов , расположенных выше главной диагонали.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.