Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

напишите программу ,если дан массив 5*5 , так чтобы по главной диагонали были 1, а остальные 0.

10-11 класс

для программы паскаль

Zuuuz 22 июля 2015 г., 13:26:54 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Vasia2334
22 июля 2015 г., 15:34:13 (8 лет назад)

var a:array[1..5,1..5] of byte;
i,j:integer;
begin
for i:=1 to 5 do begin
  for j:=1 to 5 do begin
  if i=j then a[i,j]:=1
  else a[i,j]:=0;
  write(a[i,j]:2);
  end;
writeln;
end;
end.

Ответить

Другие вопросы из категории

Каков минимальный объем памяти (в Кб), достаточный для

хранения растрового изображения размером 128 х 128 пикселей, если известно, что
используется палитра из 256 цветов.

В таблице приведены запросы к поисковому серверу. Расположите обозначения запросов в порядке возрастания количества страниц, которые

найдет поисковый сервер по каждому запросу.

Для обозначения логической операции “ИЛИ” в запросе используется символ |, а для логической операции “И” – &.

А)

мопсы & пудели & выставки

Б)

мопсы | пудели) & (выставки | прививки)

В)

(мопсы | пудели) & выставки

Г)

мопсы & пудели & выставки & прививки

ПОМОГИТЕ ПОЖАЛУЙСТА! В алфавите племени МУМУ всего 4 буквы (А, У, М, К) один знак препинания (точка) и для разделения слов используется пробел.

Подсчитали, что в популярном романе "МУМУКА" содержится всего 10000 знаков; из них букв А-4000, букв У-1000, букв М-2000, букв К-1500, точек 500, пробелов 1000. Какой объем информации содержит книга?

Напишите в си#! Ответьте плиз поддробно!

Напиши программу, вычисляющую периметр и площадь прямоугольника. Используй для этого длину и ширину прямоугольника, которые вводятся с клавиатуры.

Помогите решить задачу в паскале.Дана

строка символов р1, р2,
..., рn. Определить число вхождений в последовательность группы
букв "xyz". Вырезать
фрагмент из текста между первым и вторым вхождением группы символов "xyz".

Читайте также

№1. Дан массив из 30-ти элементов. Каждый элемент может принимать целочисленные значения от 0 до 100. Напишите программу, которая позволит найти сумму

двузначных элементов массива, которые не оканчиваются на 3. №2. Дан массив из 100 элементов. Каждый элемент может принимать целочисленные значения от 1 до 500. Напишите программу, которая позволит найти и вывести минимальное значение среди элементов массива, которые делят максимальное значение элементов массива без остатка.

№1. Дан массив из 30-ти элементов. Каждый элемент может принимать целочисленные значения от -100 до 100. Напишите программу, которая позволит

подсчитать среднее арифметическое положительных элементов массива, которые кратны первому элементу массива. №2. Дан массив из 40 элементов. Каждый элемент может принимать целочисленные значения от 0 до 200. Напишите программу, которая позволит найти наиболее часто встречающийся элемент массива

Составить программу Дан массив натуральных чисел , размерность -12 !) Заполнение массива производить с клавиатуры 2) Вывести на печать

только элементы кратные 2

3)Найти сумму первых пяти элементов

Составить программу Дан массив целых чисел , размерность -12

1) Заполнение массива производить случайными числами из диапозона [-10;35]

2)Вывести на печать только положительные элементы

3)Найти количество отрицательных элементов

Составить программу

Известны данные о выпуске прождукции ( ткани в метрах ) ткацким цехом текстильного комбината за каждый день месяца . Определить количество ткани ( метров) произведенных цехом за месяц .

Задачи паскаль, помогите пожалуйста кто. 1, Напишите программу, реализующую следующие вычисления. Дан номер месяца — целое число в диапазоне

1–12, введенное с клавиатуры (1 — январь, 2 — февраль и т. д.). Вывести название соответствующего времени года («зима», «весна», «лето», «осень»).

2, Напишите программу, реализующую следующие вычисления. Дана матрица размера M x N (числа вводятся с клавиатуры). Для каждого столбца матрицы найти произведение его элементов. Полученные значения вывести в текстовый файл.

3, Напишите программу с использованием функции CircleS(R) вещественного типа, находящей площадь круга радиуса R (R — вещественное). С помощью этой функции найти площади трех кругов с данными радиусами. Площадь круга радиуса R вычисляется по формуле S = πR2.

4, Напишите программу, реализующую следующие вычисления. Дано целое число N (1≤N≤26), введенное с клавиатуры. Вывести N первых прописных (то есть заглавных) букв латинского алфавита.

1.Дана строка: ПЛУВЕТ ЛАДКА. Напишите действия,которые необходимо сделать со строкой,чтобы получилось:ПЛЫВЕТ ЛОДКА

2.Дано слово ДЕРЕВО.Напишите действие,которое необходимо сделать со словом,чтобы получилось:ДЕЛРЕВО



Вы находитесь на странице вопроса "напишите программу ,если дан массив 5*5 , так чтобы по главной диагонали были 1, а остальные 0.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.