Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Элемент матрицы называется локальным минимумом, если

10-11 класс

он строго меньше всех имеющихся у него соседей. Подсчитать количество локальных
минимумов заданной матрицы размером 10 на 10.

Найти сумму модулей элементов, расположенных выше
главной диагонали.
на языке С

Nazkodjumaeva1 23 июня 2013 г., 19:46:48 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
KalinaKalinkina
23 июня 2013 г., 21:57:34 (10 лет назад)

for(int i=2;i<10;i++)
{
if(a[i]<a[i-1] && a[i]<a[i+1])
{sum+=abs(a[i]);}
}

Ответить

Другие вопросы из категории

Помогите пожалуйста!!!

Составить блок-схему и написать
на VBA
функцию, вычисляющую
для одномерного массива

Помогите мне пожалуйста с программой..(В паскале) Опишите процедуру поиска наибольшего и наименьшего элемента массива. С помощью этой процедуры составить

программу, которая определяет совпадают ли наибольший и наименьший элементы двух массивов A[1..n], B[1..n].

Помогите, Пожалуйста, с программой Паскаль. Рассмотрим целочисленный массив А[1..N] при N <= 100.

Написать программу, которая вычисляет среднее арифметическое элементов с четными индексами и среднее арифметическое с нечетными индексами.
Ввод: Число N и элементы массива вводятся из Файла.
Вывод: В файл должны быть введены 2 вычисленных значения

Читайте также

СРОЧНО!Пишу прогу с процедурами, которая считает количество "особых "элементов матрицы, но в конце проги не работает writeln, в чём может быть проблема?

Вот задача.
Заданная целочисленная матрица размером NXM. Определить k-количество "особых" элементов матрицы, считая элемент "особым", если в его строке слева от него находятся элементы, меньшие его, а справа - большие.
Вот мой код.И если уж у меня все плохо,то предложите свой код программы.
program samost;
const n=5;
m=5;
type tmatr = array[1..n, 1..m] of integer;
var a:tmatr;
i,j,k:integer;
procedure PrintMatrix(var g:tmatr);
begin
var i,j,k:integer;
for i:=1 to n do
begin
for j:=1 to n do
write(g[i,j]:4);
writeln
end;
end;
procedure MakeMatrix;
begin
var i,j,k:integer;
randomize;
for i:=1 to n do
for j:=1 to n do
begin
a[i,j]:=random(10)-5;
end;
end;
begin
MakeMatrix;
writeln('matrica A: ');
PrintMatrix(a);

k:=0;
for i:=1 to n do
for j:=1 to m do
begin
if (a[i,j]<a[i+1,j])and(a[i,j]>a[i-1,j]) then inc(k)
end;
writeln('kolichestvo elementov = ',k);
end.

найти максимальный по значению элемент матрицы x (n,m) (n<=10,m<=15) и увеличить его в 2 раза. после этого вычислить среднее арифмитическое

положительных элементов матрицы. полученную матрицу x и среднее арифмитическое распечатать

Элемент матрицы назовем седловой точкой,если он является наименьшим в своей строке и одновременно наибольшим в своем столбце или,наоборот,является

наибольшим в своей строке и наименьшим в своем столбце. Для заданной целой матрицы размером n*m напечатать индексы всех ее седловых точек.

Элемент матрицы назовем седловой точкой,если он является наименьшим в своей строке и одновременно наибольшим в своем столбце или,наоборот,является

наибольшим в своей строке и наименьшим в своем столбце. Для заданной целой матрицы размером n*m напечатать индексы всех ее седловых точек.

Если в прямоугольной матрице меньше половины столбцов содержит отрицательные элементы, то все элементы с нечетными номерами столбцов умножить на 10. В

противном случае все отрицательные элементы матрицы возвести в квадрат.

У меня получилось вот что:

program s455;
uses crt;
const
m=10;
n=12;
Var
A: array[1..m,1..n] of integer;
i, j, k, s: integer;

Begin
writeln('Enter size');
readln;
s:=0;
for j:=1 to m do
begin
k:=0;
for i:=1 to n do
end;
begin
if a<0 then begin
k:=1;
end;
if k=1 then s:=s+1;
end;
begin;
if k<0
then a[i, j]:=a[i, j*2-1]*10;
else a[i, j]:=a[i, j]*c [i, j]
end;
writeln

Не могу понять в чем ошибка



Вы находитесь на странице вопроса "Элемент матрицы называется локальным минимумом, если", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.