Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Исполнитель Чертежник имеет перо, которое можно поднимать, опускать и перемещать. При перемещении опущенного пера за ним остается след в виде прямой

10-11 класс

линии. У исполнителя существуют следующие команды:
Сместиться на вектор (а, Ь) – исполнитель перемещается в точку, в которую можно попасть из данной, пройдя а единиц по горизонтали и b – по вертикали.
Запись: Повторить 5[ Команда 1 Команда 2] означает, что последовательность команд в квадратных скобках повторяется 5 раз.
Чертежник находится в начале координат. Чертежнику дан для исполнения следующий алгоритм:
Сместиться на вектор (5,2)
Сместиться на вектор (-3, 3)
Повторить 3[Сместиться на вектор (1,0)]
Сместиться на вектор (3, 1)
На каком расстоянии от начала координат будет находиться исполнитель Чертежник в результате выполнения данного алгоритма?
10

Тризор 21 дек. 2015 г., 20:44:37 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Nastyabbs
21 дек. 2015 г., 22:55:29 (8 лет назад)

(8;6)
добавить все а и добавить все в
расстояние:

Ответить

Другие вопросы из категории

Помогите разобраться в задаче

const x:array [1..10] of integer=(-1,23,32,-8,27,-3,5,13,-4,17);
var i,k,s:integer; x1:array[1..10] of integer;
begin
for i:=1 to 10 do
x1[i]:=x[i];
begin
for k:=1 to 5 do
for i:=3 to 7 do if x[i]< x[i+1] then begin
S:=x1[i+1];
x1[i+1]:=x[i];
x1[i]:=s
end;
s:=x[6];
for i:=4 to 8 do s:=s+x[i] ;
writeln (s);
end;
end.

Ответ: 31. А именно, я не понимаю как именно идёт последовательность, знаю, что вложенный цикл повторяется пока не завершится, затем внешний пока не завершится. Но если оператор IF не выполняется, что следует? У меня именно в этом месте затуп. Буду признателен, если изложите по пунктам ход решения. спасибо!

Читайте также

Исполнитель КАЛЬКУЛЯТОР имеет только две команды, которым присвоены номера:

Умножь на 2

Прибавь 1

Выполняя команду номер 1, КАЛЬКУЛЯТОР умножает число на экране на 2, а выполняя
команду номер 2, прибавляет к числу на экране 1. Напишите программу, содержащую не
более 5 команд, которая из числа 6 получает число 33. Укажите лишь номера команд.

Например, программа 12122 -это программа:
Умножь на 2

Прибавь 1

Умножь на 2
Прибавь 1
Прибавь 1

которая преобразует число 5 в число 24.

B 1. У исполнителя Калькулятор две команды, которым присвоены номера:

1. возведи в квадрат,
2. прибавь 1.

Пер¬вая из них возводит число на экране в квадрат, вторая увеличивает его на 1. Запишите порядок команд в программе, которая преобразует число 1 в число 10 и содержит не более 4 команд. Указывайте лишь номера команд. (Например, программа 2122 — это программ А


прибавь 1,

возведи в квадрат,
прибавь 1,
прибавь 1.

Эта программа преобразует число 3 в число 18.)

Исполнитель КВАДРАТОР имеет только две команды, которым присвоены номера:

1.Возведи в квадрат
2.Прибавь 1
Выполняя команду номер 1, КВАДРАТОР возводит число на экране в квадрат, а выполняя
команду номер 2, прибавляет к этому числу 1. Напишите программу, содержащую не
более 4 команд, которая из числа 2 получает число 36. Укажите лишь номера команд.
Например, программа 2122 – это программа:
Прибавь 1
Возведи в квадрат
Прибавь 1
Прибавь 1
которая преобразует число 1 в число 6.
1221

У исполнителя Квадр две команды, которым присвоены номера прибавь 1 возведи в квадрат Первая из этих команд увеличивает число на эк

ране на 1, вторая - возводит в квадрат. Программа для исполнителя Квадр - это последовательность номеров и команд

Например 22111- это программа

возведи в квадрат

возведи в квадрат

прибавь 1

прибавь 1

прибавь 1

Эта программа преобразует число 3 в число 84

Запишите програму для исполнителя КвадрБ которая преобразует число 3 в число 10001 и содержит не более 6 команд

Пожалуйста объясните свой ответ



Вы находитесь на странице вопроса "Исполнитель Чертежник имеет перо, которое можно поднимать, опускать и перемещать. При перемещении опущенного пера за ним остается след в виде прямой", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.