Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

пожалуйста срочно помогите, очень прошу

5-9 класс

тема у нас Организация ветвлений в Паскале. и так, вопрос:
дано трёхзначное число. если сумма цифр числа кратно 3, тогда перевернуть число, иначе обнулить среднюю цифру
очень срочно, кто может

Mashushakudo 22 дек. 2013 г., 21:03:37 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Uma08
22 дек. 2013 г., 23:20:39 (10 лет назад)

uses crt;
var a, b, c, d, e: integer;
begin
clrscr;
writeln('введите трехзначное число');
readln(a);
b:=a div 100;
c:=a mod 100;
d:=c div 10;
c:=c mod 10;
e:=b+d+c;
if e mod 3=0
then
begin
e:=c*100+d*10+b;
writeln(e)
end
else
begin
d:=0
e:=b*100+d*10+c;
writeln(e)
end
end.

+ 0 -
Asuta000
22 дек. 2013 г., 23:56:01 (10 лет назад)

а что нужно, написать программу?

Ответить

Другие вопросы из категории

сколько концов у знака "SHARP"
Какой тип сетей (глобальные или локальные) будет использоваться для выполнения указанных ниже действий? а) вывод документа на сетевой принтер,

расположенный в соседней комнате вашей организации; б) отправка электронного письма другу из Германии; в) копирование файла со своего рабочего компьютера на сервер организации; г) обновление антивирусных баз с сайта разработчика; д) сетевая компьютерная игра с соседом по подъезду; е) поиск в Интернет информации о погоде.

1.Какое кол-во информации получит Миша после броска кубика с 16 гранями?

2.Играя в игру "Угадай число" было получено 6 бит информации. Каково было кол-во возможных событий?
3. Маша переехала в многоэтажный дом, и сообщение о том,что она живет на 24 этаже,несет 5 бит информации.Сколько этажей в доме?

Читайте также

Пожалуйста помогите!

программа фриПаскаль!
Составьте программу выводящую на экран мое имя "Алиса"
Помогите,очень прошу!

даны два числа. Если первое число нечетное, то найти сумму кубов, а иначе - куб суммы. даны три числа. Если хотя бы одно из чи

сел - отрицательное, то найти Iа+ b+cI иначе а+b+c +d в корне.

Даны три числа. Если произведение данных чисел - отрицательное, то каждое число возвести в квадрат, иначе найти модуль каждого числа

ПОМОГИТЕ ОЧЕНЬ ПРОШУ



Вы находитесь на странице вопроса "пожалуйста срочно помогите, очень прошу", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.