Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 975 ответов!

1 Написать процедуру вычисления среднего арифметического двух чисел. Числа и результат передаются в качестве параметров

10-11 класс

, в каком из двух введенных с клавиатуры целых чисел произведение цифр больше. Для подсчета произведения цифр использовать процедуру.

2

Написать процедуру вычисления среднего арифметического двух чисел. Числа и результат передаются в качестве параметров

MilenaN 20 апр. 2016 г., 1:38:00 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Julinana
20 апр. 2016 г., 2:31:14 (8 лет назад)

1) Тут в смысле надо тебе интеграл найти???? если да, то

      

Program Pr2;
uses crt;
procedure arifm(a,b:integer;var s:real);
begin
s:=(a+b)/2;
end;
procedure proiz(var a,b,c:integer);
var i,m1,m2:integer;
begin
m1:=1;m2:=1;
for i:=1 to a do m1:=m1*i;
for i:=1 to b do m2:=m2*i;
if m1>m2 then c:=m1
else c:=m2;
end;
var a,b,c:integer;
s:real;
Begin
clrscr;
readln(a,b);
arifm(a,b,s);
writeln(s);
proiz(a,b,c);
writeln(c);
end.

 

 

2)

Program Pr1;
uses crt;
procedure arifm(var a,b:integer;s:real);
begin
s:=(a+b)/2;
writeln(s:8:3);
end;
var a,b:integer;
s:real;
Begin
clrscr;
readln(a,b);
arifm(a,b,s);
end.

 

 

Ответить

Другие вопросы из категории

1)изображение имеет размер 10*10см с разрешением 1000*1000dpi и только 65536 возможных цвета.какой обьем памяти займет оно в мегабайтах? 2)картинка

200*100 пикселей имеет 256 различных оттенков.сколько памяти она займет в КБ?

перевести: число 91 из десятичной в двоичную число 1001110 из двоичной в десятичную число 17

десятичной в шестнадцатеричную

Из шестнадцатеричной в десятичную: В4

Читайте также

Помогите исправить программу. Она должна вычислять среднее арифметическое всех чисел в массиве меньших 50. Вот программа:

Program Zadacha;
Uses crt;
var a:array[1..1000] of integer;
c,i,n,s :integer;
s1: real;
begin;
clrscr;
writeln("Введите размерность массива);
readln(n);
writeln('Введите массив');
for i:=1 to n do
begin a[i]:=random(100);
if a[i]<50 then begin inc(c); s:=s+a[i];end;s:=s+a[i];s1:=s/N;
writeln('Массив A:');
for i:=1 to N do write(a[i]:4);
writeln;
writeln('Среднее арифметическое равно=',s1);
end;
end.

помогите пожалуйста сделать=)))

а) Написать программу, определяющую среднее арифметическое всех чисел от 0 до заданного пользователем.

б)Написать программу, определяющую количество четных чисел от 0 до заданного пользователем числа.

1. Задайте массив из 10 элементов с помощью датчика случайных чисел. Найдите среднее арифметическое нечетных элементов массива с нечетными

индексами. выведите на экран исходный массив и полученное среднее арифметическое.
2. Задайте массив из 10 элементов с помощью датчика случайных чисел. замените все элементы с четными индексами максимальными. Выведите на экран исходный и измененный массивы



Вы находитесь на странице вопроса "1 Написать процедуру вычисления среднего арифметического двух чисел. Числа и результат передаются в качестве параметров", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.