Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Произведение максимальных элементов массивов A и C

10-11 класс

Помогите, это Паскаль))
и объясните,если не сложно))

Alvira2 17 окт. 2016 г., 18:32:26 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Nelnura
17 окт. 2016 г., 21:06:40 (7 лет назад)

uses crt;
const n=10{количество элементов массива а};
m=15{количество элементов массива с};
var a:array[1..n] of integer;
c:array[1..m] of integer;
i,j,maxa,maxc,pr:integer;
begin
randomize;
for i:=1 to n do
begin
a[i]:=random(100);
write(a[i]:4);
end;
writeln;
for j:=1 to m do
begin
c[j]:=random(100);
write(c[j]:4);
end;
writeln;
maxa:=0;
maxc:=0;
for i:=1 to n do
if (a[i]>maxa) then maxa:=a[i]{нашли максимальный элемент массива а};
for j:=1 to m do
if (c[j]>maxc) then maxc:=c[j]{нашли максимальный элемент массива с};
pr:=1;
writeln(maxa);
writeln(maxc);
pr:=maxa*maxc;
writeln(pr);
end.




Ответить

Другие вопросы из категории

Срочно!!!!!!!!!Написать программу в паскале (и желательно блок схему) для задачи:

Ввести 10 чисел, и вывести на экран наименьшее.

Читайте также

дана программа нахождения суммы всех элементов массива. Изменить программу таким образом,чтобы:

a) массив состоял из 15 элементов вещественного типа;
b) значения элементов массива должны меняться в интервале от 0 до 5;
c) в результате выполнения программы должно быть найдено произведение всех элементов массива, а не их сумма

Program massiv;
const n=10;
Var a: array [1..n] of integer;
s,i integer;
Begin
writeln (‘ исходный массив.‘);
For i:= 1 to n do
begin
a [ i] := random (10);
write (‘a[‘i'] =', a[i], '');
end;
s:=0;
For i:= 1 to n do
s:= s+a[i];
Writeln (‘ сумма всех элементов массива S=‘, s);
end.

Паскаль помогите пжл!!!!!! Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива,

расположенных между максимальным и минимальным элементами.

Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива, расположенных между максимальным по модулю и минимальным по модулю элементами

ну или исправьте мое пжл

program fgf;
var mas:array[1..100] of real;
max,min:real;
i,n,c,b:shortint;
p:real;
f1,g:text;
begin;
assign (f1, 'input.txt');
reset (f1);
readln (f1, n);

for i:=1 to N do read (mas[i]);
max:=mas[i];
for i:=2 to N do begin
if mas[i]>max then begin
max:=mas[i];
c:=i;
end;
end;
min:=mas[1];
for i:=2 to N do begin
if mas[i]<min then begin
max:=mas[i];
b:=i;
end;
end;
close(f1);
assign (g, 'output.txt');
rewrite (g);
p:=1;
if b<c then I:=b+1 and c-1

else for I:=c+1 to b-1 do p:=p*mas[i];

if (n<3) or (b+1=c) or (c+1=b) then writeln(g,'0.00') else write(p:3:3) ;

close (g);
end.

Дан массив V[15] целочисленных элементов. Определить: 1)произведение элементов, занимающих 1,6,11 места в массиве. 2)сумму

элементов, занимающих четные места в массиве.

3)сформировать новый массив K [10] из элемаентов с 1 по 10 по формуле: K[i]=V[i]*2.

4)определить максимальный элемент массива K, его порядковый номер.

нужна программа, написанная, на языке програмирования Pascal.

Составить программу на языке Паскаль: 1)Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2)В массиве М из 10 целых

чисел найти количество элементов равных 3. 3)В массиве из 8 целых найти номер массива с наибольшим значением. 4)В массиве из 12 целых чисел найти количество и сумму элементов, расположенных до максимального элемента. 5)Для массива из 15 вещественных подсчитать количество элементов массива меньших суммы первого и последнего элементов массива.

дан целочисленный массив из 20 элементов. Элементы массива могут принимать целые числа от о до 10000 включительно. Опишите на естественном языке или на

одном из языков программирования алгоритм, позволяющий найти и вывести максимальное значение среди трехзначных элементов массива, оканчивающихся на 0



Вы находитесь на странице вопроса "Произведение максимальных элементов массивов A и C", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.