Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Удалить все элементы, кратные 3 или 5

10-11 класс

Помогите найти, где я ошибся, ибо сам не смог этого сделать!
program udalenie;
const
n=20;
Type
Tarray=array[1..n] of integer;
var i,s,j:integer;
a:Tarray;
begin
randomize;
for i:=1 to n do begin
a [i]:=random(100);
write(a[i]:3, ' ' );
end;
s:=0;
for i:=1 to n do
begin
if (a[i] mod 3=0) or (a[i] mod 5=0) then
begin
s:=s+1;
for j:=i to n-s do
a[i]:=a[i+1];
a[n+1-s]:=0;
end
end;
write('dsd');
for i:=1 to n-s do
write(a[i]:3, ' ' );
end.

Slavdowzhenko2 20 апр. 2013 г., 17:12:17 (11 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
хомка123
20 апр. 2013 г., 17:44:01 (11 лет назад)

1) опечатка в строчке a[i]:=a[i+1]; - вместо i должно быть j
2) косяк в алгоритме: после того, что нашелся нехороший элемент, все элементы правее этого сдвигаются на 1 влево. Но после этого тот элемент, который до сдвига был следующим - нигде не проверяется. Лечится это, например, добавлением дополнительного repeat ... until цикла, или заменой внешнего цикла for на какой-нибудь еще, позволяющий менять счетчик внутри цикла.

+ 0 -
Phill98
20 апр. 2013 г., 20:43:07 (11 лет назад)

Какое было задание? Что нужно от программы?

+ 0 -
Morozovyurik
20 апр. 2013 г., 22:24:54 (11 лет назад)

вводишь случайных 20 чисел, считаешь сколько чисел делится на 3 или на 5. А дальше?

+ 0 -
Smu100
20 апр. 2013 г., 23:05:43 (11 лет назад)

Создается массив из 20 рандомных чисел, нужно удалить из данного массива элементы кратные 3 и 5 то есть,вывести в конце этот массив такой же только, чтобы в нём не было чисел кратных 3 и5

Ответить

Другие вопросы из категории

решить в паскале

________________________________________________

Для кодирования некоторой последовательности состоящей из букв к л м н, решили использовать неравномерный двоичный код, удовлетворяющий условию Фано. Для

буквы Л использовали кодовое слово 1, для буквы М кодовое слово 01. Какова наименьшая возможность суммарная длина всех четырех кодовых слов?

Какие свойства реальных объектов воспроизводят следующие модели?

• Муляжи продуктов в витрине магазина;
• чучело птицы;
• заводной игрушечный автомобиль.

Читайте также

Информатика(Паскаль) помогите пожалуйста

Создать массив случайных чисел, вывести его на экран в строчку. Из массива удалить все элементы, принадлежащие заданному интервалу

Народ,помогите написать программу на dev c++,объяснить)

В отчете предоставить блок-схемы всех
функций, текст программы.

Задача : В целочисленном массиве Х(N) удалить все элементы, расположенные
между максимальным и минимальным элементами. Найти среднее
арифметическое элементов массива до и после удаления. В программе
написать функции: удаления элемента, поиска номеров минимального и
максимального элементов, определения среднего арифметического
элементов массива.



Вы находитесь на странице вопроса "Удалить все элементы, кратные 3 или 5", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.