Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Помогите пожалуйста

5-9 класс

1. Чему будет равна переменная «c» после выполнения этой программы:
a := 28;
b := 7;
b := a div b + b;
c := a mod b + a;
Ответ:
2. Чему будет равна переменная «c» после выполнения этой программы:
a := 26;
b := 6;
c := a mod b + b;
Ответ:
3. Чему будет равна переменная «c» после выполнения этой программы:
a := 28;
b := 7;
c := a div b + a;
Ответ:
4. Чему будет равна переменная «c» после выполнения этой программы:
a := 22;
b := 4;
b := a div b;
c := a div b;
Ответ:
5. Чему будет равна переменная «c» после выполнения этой программы:
a := 26;
b := 6;
b := a mod b + 4;
c := a mod b + 1;
Ответ:
6. Чему будет равна переменная «c» после выполнения этой программы:
a := 20;
b := 3;
b := a div b;
c := a mod (b + 1);
Ответ:
7. Чему будет равна переменная «c» после выполнения этой программы:
a := 28;
b := 7;
b := a mod b;
c := a div (b + 1);
Ответ:

Лиза0105 18 нояб. 2013 г., 22:13:01 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Mashaaaaaaaa
18 нояб. 2013 г., 23:04:14 (10 лет назад)

div - результат целочисленного деления,   например,   28 div 5 = 5
mod - остаток от деления, например, 28 mod 5 = 3
1.
a := 28;
b := 7;
b := a div b + b=[28:7]+7=4+7=11
c := a mod b + a=остаток от [28:11]=6+28=34
Итак,  c= 34
    дальше - аналогично:
2.    с=8  3. с=32  и т.д.

Ответить

Читайте также

Помогите пожалуйста ! срочно надо!!!...в заданной последовательности целых чисел определите сумму элементов кратных 10! пример задачки вот именно под

типо по такой же системе которую щас напишу! program Maximum; i,n,max:integen; begin writeln ( 'введи элементы массива для поиска максимума'); for i:=1 to 10 do begin write ('a [', i ,']=');readln (a [ i ] ) ;end; max:=a[1]; for i = 2 to 10 do if a [ i ] > max then begin max:=a [ i ] ; n:= i ; end; writeln ('найти наибольший элемент ',max ,' под номером ', n); вот наподобие этого примера нужно построить мою задачу! в заданной последовательности целых чисел определите сумму элементов кратных 10. Помогите пожалуйста!!!

ПАСКАЛЬ,ПОМОГИТЕ ПОЖАЛУЙСТА

Даны натуральное число n и вещественные числа a1, a2, ..., an. Определить среднее арифметическое вещественных чисел...

ПАСКАЛЬ,ПОМОГИТЕ ПОЖАЛУЙСТА

Помогите пожалуйсто решить прошу очень срочно!!!!

1. Чему равны значения переменных r, a, d?
a:=5; b:=20; c:=-7;
d:=2.5;
r := a+(4*b+c)*d;
a:= a+4;
d:=a*7;

2. В пяти тестовых опросах мальчик получил оценки. Составьте программу, которая определит среднее значение оценок, полученных мальчиком в пяти опросах.

3*. Задача. «Покупка в магазине»
Человек делает в магазине покупки. Определите сколько денег у него останется после покупки в магазине перчаток стоимостью А руб., портфеля стоимостью B руб. и галстука стоимостью D руб. Все исходные данные задаются с клавиатуры.

Исходные данные.
a — стоимость перчаток;
b — стоимость портфеля;
d — стоимость галстука;
dengi — количество денег у человека.
Все эти переменные будут вещественного типа.
Результат.
ostatok — количество денег, которое останется у человек (вещественный тип).
Метод решения.
ostatok = dengi – a – b – d
Написать программу, реализующую данную задачу
Помогите пожалуйсто решить очень срочно!!!!!!

Как пройти 7 уровень в час кода ам няма помогите пожалуйста!!

Как пройти 9 уровень в час кода ам няма помогите пожалуйста!!

Люди Люди Люди если вы читаете это сообщение значит вы просто обязаны помочь! пожалуйста если у вас есть паскаль помогите пожалуйста решить первое и

второе задание ну или хотя бы только первое .Это вопрос жизни и смерти помогите пожалуйста P.S задание во вложениях.заранее спасибо и знайте если вы поможете значит вы самый добрый и отзывчивый человечек!)



Вы находитесь на странице вопроса "Помогите пожалуйста", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.