Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

имеется вещественный массив, состоящий из 9 элементов.найти сумму, среднее арифметическое и произведение всех элементов.

10-11 класс

Анонимус13 29 сент. 2015 г., 2:41:46 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
теплюк
29 сент. 2015 г., 5:03:41 (8 лет назад)

var a: array [1..9] of real;

s,p: real;

BEGIN

  p:=1;

  s:=0;

  for i:= 1 to 9 do

  begin

    read(a[i]);

    s:= s+a[i];

    p:=p*a[i];

  end;

  writeln("Summa=",s);

  writeln("Srednee arefmeticheskoe=",s/n);

  writeln("Proizvedenie=",p);

END.

Ответить

Другие вопросы из категории

№1.)

Дан массив целых чисел, состоящий из 10 элементов. Заполнить его с клавиатуры.
Найти:
-Удвоенную сумму положительных элементов;
вывести значения тех элементов, которые меньше заданного числа A кратны 3.
№2.)
Из элементов массива P сформировать массив M той же размерности по правилу: если номер четный, то M[i]=P[i]*P[i], если нечетный, то M[i]=P[i]-1.
№3.)
В массиве поменять местами 3 и последний элемент.

Установите соответствие

1.лазерные черно-белые
2.струйные
3. матричные



б)порошкообразный
с)жидкий
а)красящая лента

Читайте также

1)дан одномерный массив из 5 элементов.найти сумму положительных элементов. 2)Дан одномерный массив из 7

элементов.Найти колличество четных положительных элементов.

3)Дан массив из 6 элементов.Найти произвдение положительных из них.

Паскаль помогите пжл!!!!!! Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива,

расположенных между максимальным и минимальным элементами.

Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива, расположенных между максимальным по модулю и минимальным по модулю элементами

ну или исправьте мое пжл

program fgf;
var mas:array[1..100] of real;
max,min:real;
i,n,c,b:shortint;
p:real;
f1,g:text;
begin;
assign (f1, 'input.txt');
reset (f1);
readln (f1, n);

for i:=1 to N do read (mas[i]);
max:=mas[i];
for i:=2 to N do begin
if mas[i]>max then begin
max:=mas[i];
c:=i;
end;
end;
min:=mas[1];
for i:=2 to N do begin
if mas[i]<min then begin
max:=mas[i];
b:=i;
end;
end;
close(f1);
assign (g, 'output.txt');
rewrite (g);
p:=1;
if b<c then I:=b+1 and c-1

else for I:=c+1 to b-1 do p:=p*mas[i];

if (n<3) or (b+1=c) or (c+1=b) then writeln(g,'0.00') else write(p:3:3) ;

close (g);
end.

Помогите пожалуйста решить задачки в паскале.

1.В одномерном массиве перенести элемент, стоящий на первом месте в конец массива.
2.вывести на печать номера точек, лежащих в круге радиусом r. Координаты точек заданы массивами (x1,x2,...,x10), (y1,y2,...,y10).
3.В одномерном массиве найти сумму положительных, произведение отрицательных, количество четных элементов.
4.Дан массив, состоящий из 50 элементов, найти предпоследний нечетнный элемент.

Задан одномерный массив размером 40. Определите количество элементов массива и среднее арифметическое значение этих элементов, которых больше заданного

числа 7 и меньше 10. Вывести количество элементов массива и среднее арифметическое значение этих элементов, которых больше заданного числа 7 и меньше 10 на монитор

Добрый день. Помогите пожалуйста решить две задачи... №1 Дан массив из 25 элементов,найти сумму 4-х наибольших и 4-х наименьших э

лементов. Результат распечатать в виде:

Сумма наибольших=

Сумма наименьших=

№2

Даны два массива по 30 элементов. Найти среднее арифмитическое для элементов 1-го массива,номера которых больше номера минимального элемента 2-го массива

Заранее спасибо



Вы находитесь на странице вопроса "имеется вещественный массив, состоящий из 9 элементов.найти сумму, среднее арифметическое и произведение всех элементов.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.