Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Паскаль. помогите. Программа должна менять знак всех положительных элементов, расположенных в строке и столбце матрицы с максимальным элементом, но она

10-11 класс

меняет только нижнюю строчку и левый столбец, где ошибка?

кира50502 31 янв. 2016 г., 17:29:17 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
РафАеЛкА
31 янв. 2016 г., 20:10:26 (8 лет назад)

                                  program gt;
Uses Crt;
var
a:array[1..10,1..10]of integer;
n,i,j,max,h,l:integer;
begin   
 RepeatWrite('Ââåäèòå ðàçìåðíîñòü ìàòðèöû (n>0)and(n<=10)');       
 Readln(n);   
 Until( (n>0)and(n<=10) );   
 max:=-maxint;   
For i:= 1 to n do   
    For j:= 1 to n do           
 BEGIN           
Read(a[i,j]);
if(a[i,j]>max)then begin
max:=a[i,j];
h:=i;  l:=j;
end;
end;
for j:=1 to n do
a[H,j]:=-a[H,j];
for i:=1 to n do
a[i,L]:=-a[i,L];
a[H,L]:=-a[H,L];
writeln;
for i:=1 to n do
begin
for j:=1 to n do
write(a[i,j]:3,' ');
writeln;
end;
end.

Ответить

Другие вопросы из категории

Читайте также

Всем привет, помогите написать программу в паскале, смысл прост. Программа должна переводить число из шестнадцатиричной системы счисления в дестяричную и

наоборот, тоесть после вводе числа- FFF программа должна вывести число 4095 и ниже снова FFF, программа должна быть простая и не слишком умная. Заранее спасибо

Тест по паскалю!!!

100. Назовите все отличия функций от процедур?
а) функция передает в точку вызова скалярное значение, а процедура - нет
б) имя процедуры может состоять из трех символов, а функция - нет
в) процедура имеет структуру, повторяющую структуру программы, а в функции отсутствует блок описания переменных
г) имя функции может входить в выражении как операнд

101. С помощью каких параметров происходит передача данных из главной программы в подпрограмму?
а) фактических
б) формальных
в) неформальных
г) подпрограммных

102. Выберите неправильную форму записи оператора цикла
а) WHILE I<5 DO I:=I+1
б) WHILE I<5 DO BEGIN I:=I+1; WRITELN(I); END
в) WHILE I<5 TO BEGIN I:=I+1; WRITELN(I); END

103. Какое выражение обеспечивает генерирование случайных чисел в диапазоне [4,10[
а) 4+RANDOM(6)
б) 6+RANDOM(4)
в) RANDOM(4,6)

104. что означает FV в команде read(FV, x1, x2,..., xn) в Паскале ?
а) формат ввода
б) переменную, связанную с файлом, откуда берется информация
в) фиксированную величину
г) первую переменную величину для ввода информации

105. Каким окажется результат выполнения следующего фрагмента кода X:= 5; Y:= X+1; Writeln('Х=',X, Y=',Y);?
а) X=6 Y=5
б) X=5 Y=5
в) X=5 Y=6

106. Какое значение примет переменная Х после выполнения команды X:=SQR(4)/2*2?
а) 4
б) 2
в) 16

107. Каким окажется результат выполнения следующего фрагмента кода: X:= 5; Y:= 8; Т:= Х; X:=Y; Y:= T; Writeln('Х=', X, Y=',Y);?
а) X=5 Y=8
б) X=8 Y=5
в) X=5 Y=5

108. Логическое выражение
(N Mod 10 Mod 2) Or (N Div 10 Mod 10 Mod 2 = 0) Or (N Div 100 Mod 2 = 0)
должно принимать значение TRUE тогда и только тогда, когда истинно высказывание
а) в трёхзначном натуральном числе все цифры чётные
б) в трёхзначном натуральном числе одна чётная цифра
в) в трёхзначном натуральном числе две чётных цифры
г) в трёхзначном натуральном числе хотя бы одна чётная цифра

109. Цикл в фрагменте программы P := 4; Repeat P := P * 0.1 Until P < 0.0001; будет исполнен?
а) 0 раз
б) 1 раз
в) 4 раза
г) 5 раз

110. Значение R после выполнения операции логического присваивания
R := Not (A Or B Or (X > 2) And (Y < 0))
при A = False, B = False, X = 3, Y = 2 будет равно
а) -1
б) False
в) True
г) 0

111. Значения переменных a и b после выполнения следующих действий
a := 15 Div (16 Mod 7); b := 34 Mod a * 5 - 29 Mod 5 * 2;
будут равны
а) a = 1, b = 160
б) a = 1, b = 4
в) a = 7, b = 25
г) a = 7, b = 22

112. Во фрагмент алгоритма, печатающий все двузначные числа, в записи которых есть цифра N или сумма цифр которых равна самим числам, нужно вписать логическое выражение
а) (P1 = N) Or (P2 = N) And (S = K)
б) (P1 = N) Or (P2 = N) Or (S = K)
в) (P1 = N) And (P2 = N) Or (S = K)
г) ((P1 = N) Or (P2 = N)) And (S = K)

113. Тело цикла в программе a := 1; b := 1; While a + b < 8 Do begin a := a + 1; b := b + 2 end;
выполнится?
а) 1 раз
б) 2 раза
в) 3 раза
г) бесконечное число раз

114. Задана строка St (см Фрагмент алгоритма)
а) определяет количество цифр в строке
б) подсчитывает количество нулей в строке
в) определяет сумму номеров позиций в строке, где стоят цифры
г) подсчитывает сумму цифр в строке;

115. Задан двумерный массив X[1..n, 1..m]. Процедура
а) к элементам столбцов в первой половине матрицы прибавляет элементы первого столбца соответствующей строки
б) добавляет к матрице еще M столбцов с элементами, равными соответствующим элементам первого столбца
в) к элементам четных столбцов прибавляет элементы первого столбца соответствующей строки
г) к элементам четных строк прибавляет элементы первой строки соответствующего столбца;

116. Задан двумерный массив X[1..n, 1..m]. Функция возвращает значение
а) True, если все элементы массива ненулевые
б) True, если в массиве есть элемент, равный нулю
в) False, если в массиве есть элемент, равный нулю
г) Not t;

117. Значение R после выполнения операции логического присваивания
R := Not (A Or B Or (X > 2) And (Y < 0))
при A = False, B = False, X = 3, Y = 2 будет равно
а) 1
б) False
в) True
г) 0

118. В каком фрагменте программы подсчитывается сумма элементов квадратной матрицы, расположенных выше главной диагонали?

а) For i:= 1 to n do
For j:= 1 to n do
If i<=j then
S:=s+a[I,j];

б) For i:= 1 to n do
For j:= i+1 to n do
S:=s+a[I,j];

в) For i:= 1 to n do
For j:= 1 to n do
If i>j then
S:=s+a[I,j];


Задачи паскаль, помогите пожалуйста кто. 1, Напишите программу, реализующую следующие вычисления. Дан номер месяца — целое число в диапазоне

1–12, введенное с клавиатуры (1 — январь, 2 — февраль и т. д.). Вывести название соответствующего времени года («зима», «весна», «лето», «осень»).

2, Напишите программу, реализующую следующие вычисления. Дана матрица размера M x N (числа вводятся с клавиатуры). Для каждого столбца матрицы найти произведение его элементов. Полученные значения вывести в текстовый файл.

3, Напишите программу с использованием функции CircleS(R) вещественного типа, находящей площадь круга радиуса R (R — вещественное). С помощью этой функции найти площади трех кругов с данными радиусами. Площадь круга радиуса R вычисляется по формуле S = πR2.

4, Напишите программу, реализующую следующие вычисления. Дано целое число N (1≤N≤26), введенное с клавиатуры. Вывести N первых прописных (то есть заглавных) букв латинского алфавита.

Ребятушки помогите пожалуйста по програмированию)) в паскале

Написать программу, выполняющую поиск максимальных элементов в каждой строке заданной матрицы.



Вы находитесь на странице вопроса "Паскаль. помогите. Программа должна менять знак всех положительных элементов, расположенных в строке и столбце матрицы с максимальным элементом, но она", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.