Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

12,277

10-11 класс

Выяснить, есть ли в массиве строки, в которых буква A расположена справа от буквы d (известно, что буква d в каждой строке единственная).

Xxxhello 30 дек. 2013 г., 4:37:54 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
AYUTASUPERS
30 дек. 2013 г., 5:48:28 (10 лет назад)

const n=20;
var i,f,k,j:integer;
s:string;
a:array[1..n] of string;
begin
k:=0; j:=0;
writeln('введите количество строк в массиве');
readln(f);writeln('заполните массив');
for i:=1 to f do
readln(a[i]);
for i:=1 to f do
begin
 j:=pos('d',a[i]);
 s:=a[i];
 while (pos('a',s)<j) and (pos('a',s)<>0) do
  begin
  delete(s,pos('a',s),1); j:=j-1;
  end;
 if pos('a',s)>j then k:=k+1;
 end;
if k=0 then writeln('таких строк нет') else writeln('такие строки есть');
end.

+ 0 -
12345kir
30 дек. 2013 г., 6:37:31 (10 лет назад)

Отлично. Можно сравнить с VBA Excel

+ 0 -
саша0999
30 дек. 2013 г., 7:55:02 (10 лет назад)

Могу в VBA Excel, если устроит.

+ 0 -
Vera201223
30 дек. 2013 г., 8:54:48 (10 лет назад)

Паскаль АБС

+ 0 -
6cRyc2Na
30 дек. 2013 г., 11:38:52 (10 лет назад)

Если никто не напишет, завтра прикреплю пример в VBA, там команды почти соответствуют Паскалю, сами конвертируете.

+ 0 -
K05082000
30 дек. 2013 г., 12:33:38 (10 лет назад)

ок

+ 0 -
SnackDark
30 дек. 2013 г., 13:20:03 (10 лет назад)

сколько строк может быть в массиве?

Ответить

Другие вопросы из категории

000010100001001 (2) в десятичную систему
Буква «I» в таблице кодировки

символов имеет десятичный код 105. Что зашифровано последовательностью
десятичных кодов: 108 105 110
107?

Читайте также

Составить программу на языке Паскаль: 1)Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2)В массиве М из 10 целых

чисел найти количество элементов равных 3. 3)В массиве из 8 целых найти номер массива с наибольшим значением. 4)В массиве из 12 целых чисел найти количество и сумму элементов, расположенных до максимального элемента. 5)Для массива из 15 вещественных подсчитать количество элементов массива меньших суммы первого и последнего элементов массива.

1. При совершении сделки купец получил 12 одинаковых по виду золотых монет. Ему стало известно, что одна из монет фальшивая и отличается от настоящей

монеты только весом. Для определения фальшивой монеты он пронумеровал монеты числами от 1 до 12 и провел три взвешивания на рычажных весах. Обозначив через Vi – вес монеты с номером i, он записал результаты взвешиваний следующим образом: V2 + V4 + V5 + V6< V3 + V7 + V8 + V9; V1 + V2 + V3 + V5> V4 + V6 + V10 + V11; V1 + V4 + V7 + V10>V5 + V6 + V9+ V12. Найдите фальшивую монету.

1) Найти сумму четных элементов массива F(12), значения которых больше 2. Вывести также число таких элементов, массив расположен в ячейках D2:D14 листа

Сумма.
Массив: -7 0 3 1 -8 -3 5 3 12 15 40 7

2) Определить в Exel адрес первого числа больше 2.

Наташа набрала текст на компьютере. Текст получился на 12 страниц, каждая страница состоит из 24 строк, в каждой строчке 21 символ. Определите

информационный объём получившегося текста в одной из кодировок Unicode? в которой каждый символ кодируется 16 битами.
А)12, 4Кбайт
В)16,1Кбайт
С)300Кбайт
D)1024Кбайт

Составить программу Дан массив натуральных чисел , размерность -12 !) Заполнение массива производить с клавиатуры 2) Вывести на печать

только элементы кратные 2

3)Найти сумму первых пяти элементов

Составить программу Дан массив целых чисел , размерность -12

1) Заполнение массива производить случайными числами из диапозона [-10;35]

2)Вывести на печать только положительные элементы

3)Найти количество отрицательных элементов

Составить программу

Известны данные о выпуске прождукции ( ткани в метрах ) ткацким цехом текстильного комбината за каждый день месяца . Определить количество ткани ( метров) произведенных цехом за месяц .



Вы находитесь на странице вопроса "12,277", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.