Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

напишите программу, в которой осуществляется ввод целых чисел (ввод осуществляется пока не будет введен ноль) и определение максимального ( наибольшего)

5-9 класс

из введенных чисел. используйте оператор repeat.

Peinxwar 18 нояб. 2016 г., 4:50:14 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
55579
18 нояб. 2016 г., 6:09:31 (7 лет назад)

var
  Max, N: Integer;
  I: Integer;
begin
  I:=0;

  Repeat
    ReadLn(N);
    
    if I = 0 then
      Max:=N
    else if N > Max then
      Max:=N;

    Inc(N);
  Until(N = 0); 

  WriteLn('Max = ', Max);
end.

Ответить

Другие вопросы из категории

Скорость передачи данных через Adsl-соединение равна 256000 бит/с. Передача файла через

это соединение заняла 2 минуты. Определите размер файла в килобайтах.

решите плиз все задачи
0,1000110 в 2 с. счисл перевести в 7,10,16 систему

137 в 10 с.с перевести в 16 систему

Читайте также

Условие: Напишите прогу в которой осуществляется ввод целых чисел и подсчет введенных положительных и отрицательный чисел.

Задание: преобразуйте в условие окончания работы в условие продолжение работы(while)

Условие: Напишите прогу в которой осуществляется ввод целых чисел и подсчет введенных положительных и отрицательный чисел.

Задание: преобразуйте в условие окончания работы в условие продолжение работы(while)



Вы находитесь на странице вопроса "напишите программу, в которой осуществляется ввод целых чисел (ввод осуществляется пока не будет введен ноль) и определение максимального ( наибольшего)", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.