Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 975 ответов!

среди вводимых через х 10 чисел нужно найти максимальное и минимальное числа. составьте программу в паскале с помощь массива

5-9 класс

ПАВЛИК2013 16 нояб. 2013 г., 15:22:58 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Peredumovv
16 нояб. 2013 г., 16:21:45 (10 лет назад)

var
a:array[1..10] of integer;
min,max,i:integer;
begin
min:=999999;
for i:=1 to 10 do
begin
read(a[i]);
if a[i]>max then max:=a[i];
if a[i]end;
writeln('min = ',min);
writeln('max = ',max);
end.

Ответить

Читайте также

Поомогите, пожайлуста. Нужно составить программу на паскале. Ежемесячная стипендия студента составляет a руб.Расходы на проживание превышают стипендию

и составляют b руб(в месяц).Рост цен ежемесячно увеличивает расходы на 3%,составьте программу расчета необходимой суммы денег,которую нужно единовременно попросить у родителей,чтобы можно было прожить 10 месяцев,используя эти деньги.

Нужно решить задачку:

Найти максимальное и минимальное число
(Блок схема и программа)
Работаем в Паскале

Помогите написать программы >< Задача 1: Среди целых чисел найти минимальное число, которое больше 20 и делится на 17. Задача 2:

Найти максимальное натуральное число меньше 5000, которое делится нацело на 39.

Задача 3: 1 марта в банк положили 1000 руб. Каждый месяц вклад увеличивается на 2% от имеющейся суммы.

а) за какой месяц величина процентной надбавки превысит 30 руб.?

б) через сколько месяцев размер вклада превысит 1200 руб.? Заранее спасибо)

Решить задачи на языке программирования в Turbo Pascal: 1) Дан массив, состоящий из 10 чисел, значения могут быть

от -100 до 100. Определить минимальное положительное число.

2) Дан массив, состоящий из 10 чисел. Найдите номера тех элементовв масива, которые наименее различаются.



Вы находитесь на странице вопроса "среди вводимых через х 10 чисел нужно найти максимальное и минимальное числа. составьте программу в паскале с помощь массива", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.