Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 975 ответов!

Составить программу нахождения площади треугольника по формуле Герона.

5-9 класс

Входные данные длины сторон треугольника.
Выходные данные периметр треугольника, площадь треугольника.

ПоляМотырева 18 марта 2014 г., 13:59:00 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Sgbs
18 марта 2014 г., 14:46:41 (10 лет назад)

program abc;
uses crt;
var a,b,c,P,S,P2:real;
begin
writeln('Введите первую сторону: ');
readln(a);
writeln('Введите вторую сторону: ');
readln(b);
writeln('Введите третью сторону: ');
readln(c);
if (a+b<c) or (a+c<b) or (b+c<a) then
writeln('Ваш треугольник не существует')
else
P:=a+b+c;
P2:=P/2;
S:=sqrt(P2*(P2-a)*(P2-b)*(P2-c));
writeln('Периметр = ',P);
writeln('Площадь = ',S);
end.

Ответить

Другие вопросы из категории

Помогите пожалуйста)

Тест по информатике

Жыли четыре друга. У них были имена Альберт, Карл, Дитрих и Фридрих. Фамилии друзей такие же, что и имена, только так, что ни у кого из них имя и фамилия

Определите фамилию и имя каждого мальчика, если известно, что имя мальчика, у которого фамилия Фридрих, это фамилия того мальчика, имя которого - фамилия Карла.

Подпись :Пуф-Пуф

Читайте также

1. Составьте блок-схему алгоритма и программу вычисления площади треугольника по трем сторонам. 2. Составьте программу вычисления объема, площади полной

поверхности, суммы ребер прямоугольного параллелепипеда. 3. Составьте программу вычисления диагоналей ромба по стороне и углу.

1)Составить программу нахождения суммы квадратов чисел от 25 до 125.

2) составить программу нахождения чисел от 10 до 99 сумма квадратов которых кратна 13 (mod=0)
3) найти сумму всех целых нечетных чисел меньших 100
4) найти сумму чисел в диапазоне от A до B кратных четырём. Числа А и В вводятся с клавы.
5) Найти все натуральный делители натурального числа n

Составить алгоритм нахождения площади и длины окружности если известен радиус.

Составить алгоритм нахождения площади и длины окружности если известен диаметр.



Вы находитесь на странице вопроса "Составить программу нахождения площади треугольника по формуле Герона.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.