Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Команда записана на For, нужно эту же программу записать на While

5-9 класс

For x:= -5 to 8 do
Begin
y:=abs(x);
Writeln(y);
end;

Forverd 06 авг. 2014 г., 20:47:39 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
LS8
06 авг. 2014 г., 22:07:44 (9 лет назад)

x:=-5;
while x<=8 do begin
y:=abs (x);
Writeln (y);
x:=x+1;
end;

Ответить

Другие вопросы из категории

Ана­ло­го­вый зву­ко­вой сиг­нал был дис­кре­ти­зи­ро­ван сна­ча­ла с ис­поль­зо­ва­ни­ем 64 уров­ней дис­кре­ти­за­ции сиг­на­ла, а затем с

ис­поль­зо­ва­ни­ем 4096 уров­ней дис­кре­ти­за­ции сиг­на­ла. Во сколь­ко раз уве­ли­чил­ся ин­фор­ма­ци­он­ный объем оциф­ро­ван­но­го звука?

Кумир! Помогите, пожалуйста с задачей:

Заполните массив двадцатью числами так, что каждый пятый элемент равен 100, а остальные равны своему номеру.

Читайте также

Помогите, пожалуйста, очень нужно! Срочно!:( 1) Не используя функцию возведения в квадрат, напишите на языке Паскаль наиболее короткие алгоритмы

вычисления: а) y=x^10 б) y=x^15. Постараться использовать минимальное количество дополнительных переменных. 2) Дана сторона равностороннего треугольника. Найти площадь этого треугольника, его высоты, радиусы вписанной и описанной окружностей. Программу записать на языке Паскаль. 3) Дана величина А, выражающая объём информации в байтах. Перевести А в более крупные единицы измерения информации. Программу записать на языке Паскаль

Исполнитель Чертёжник перемещается на координатной плоскости, оставляя след в виде линии. Чертёжник может выполнять команду Сместиться на (a, b) (где a, b

– целые числа), перемещающую Чертёжника из точки с координатами (x, y) в точку с координатами (x + a, y + b). Если числа a, b положительные, значение соответствующей координаты увеличивается, если отрицательные – уменьшается.
Например, если Чертёжник находится в точке с координатами (2,3), то команда Сместиться на (-5, 2) переместит Чертёжника в точку (-3 ,5).
Запись
Повтори k раз
Команда1 Команда2 Команда3
конец
означает, что последовательность команд Команда1 Команда2 Команда3 повторится k раз.
Чертёжнику был дан для исполнения следующий алгоритм:
Повтори 3 раз
Сместиться на (-1,-5) Сместиться на (-2, -2) Сместиться на (4, 1)
конец
Какую команду надо выполнить Чертёжнику, чтобы вернуться в исходную точку, из которой он начал движение?Ответ:

Сместиться на (–3, –6)
Сместиться на (-3, 6)
Сместиться на (-1, 2)
Сместиться на (1, -2)

1) Исполнитель вычислитель умеет выполнять только две команды: умножить на 2 и брибавлять 1. Придумайте для него наиболее короткий план получения из 0

числа 50.

2) Из 9 монет одинакового достоинства одна фальшивая ( более легкая). За сколько взвешиваний на чашечных весах без гирь вы можете ее определить?

3) Где окажется исполнитель, вы полнивший 16 раз подряд следующую группу команд?

ПРОЙТИ 10 МЕТРОВ ВПЕРЕД

ПОВЕРНУТЬ НА 90 ГРАДУСОВ ПО ЧАСОВОЙ СТРЕЛКЕ

4) Используя эту блок-схему, разработайте рациональные алгоритмы получения из числа 0 чисел 1024 и 500. ( см. фотографию)

Помогите решить эти 16 вариантов, или хотя бы несколько. Что нужно сделать: Составить программу в Pascal ABC( Нужно сделать так, чтобы вы вводили

координаты х и у и программа проверяет, подходит ли эта точка к графику или нет. Пример на 2 фото.
Очень нужно. 80 баллов

Geany,пожалуйста

Вывести на экран строчку из 10 единиц. Затем в этой же программе вывести на экран 5 строчек по 10 единиц. (нужно повторять цикл for)



Вы находитесь на странице вопроса "Команда записана на For, нужно эту же программу записать на While", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.