Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 975 ответов!

роверить есть ли в заданном векторе А=а1,а2,, аn элементы равны нулю

10-11 класс

Rizwanowa182 28 мая 2013 г., 20:45:45 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
лёва25
28 мая 2013 г., 21:22:27 (10 лет назад)

var a:array[1..10000] of real;
i,n,f:integer; 
begin
write('Введите размерность вектора n = '); readln(n);
for i:=1 to n do
if a[i]=0 then f:=1;
if f=1 then writeln ('В заданном векторе есть элементы равные 0')
else writeln ('В заданном векторе нет элементов равных 0');
end.

+ 0 -
Nneretina2012
29 мая 2013 г., 0:00:06 (10 лет назад)

проверить есть ли в заданном векторе А=а1,а2,, аn элементы равныю нулю

Ответить

Другие вопросы из категории

Помогите пожалуйста)
написать программу. Программа должна осуществлять ввод и печать исходного одномерного массива; выполнять в соответствии с условиями действия и печатать

результаты. Вычислить сумму ненулевых чисел, стоящих на четных местах, и подсчитать количество чисел, принадлежащих промежутку [M, K].

Читайте также

Ребят, помогите пожалуйста объяснить задачи!!!

В целочисленной
последовательности есть нулевые элементы. Создать массив из номеров этих
элементов.



Program
Om1;

Uses
crt;

Var

a :array
[1..100] of real;

i,n,j :
integer;

x :
array [1..100] of real;

Begin

clrscr;

write('n=');readln(n);

for i:=1
to n do

readln(a[i]);

j:=1;

for i:=1
to n do

if
a[i]=0 then

begin

x[j]:=i;

j:=j+1

end;

for i:=1
to j-1 do

write(x[i],' ');

End.


Дана последовательность
целых чисел а1, а2….аn.
Выяснить какое число встречается раньше, положительное или отрицательное.


Program
num2;

Uses
crt;

VAr

a :array
[1..100] of real;

i,n :
integer;

Begin

clrscr;

write('n=');readln(n);

for i:=1 to n do

readln(a[i]);

for i:=1
to n do

begin

if
a[i]<>0 then

if
a[i]>0 then

begin

writeln('Положительное встречается раньше');

break

end else

begin

writeln('Отрицательное встречается раньше');

break

end;

end;

End.


Дана последовательность
действительных чисел а1, а2….аn. Выяснить будет ли она возрастающей.


Program
num4;

Uses
crt;

Var

a :
array [1..100] of real;

i, n, j
:integer;

Begin

clrscr;

write('n=');readln(n);

a[n+1]:=a[n]+1;

for i:=1
to n do

readln(a[i]);

j:=0;

i:=1;

while
i<n do

begin

if
a[i]<a[i+1] then

begin

j:=j+1;

i:=i+1

end

else

begin

writeln('Последовательность невозрастающая');

break

end;

end;

if i=n then writeln('Последовательность возрастающая');

End.




Найти самую большую цифру
целого числа.


Program
rar;

uses
crt;

var
n:longint;

b:byte;

Дан двумерный массив

размерностью n х m,
заполненный случайными числами. Определить, есть ли в данном массиве строка,
содержащая больше положительных элементов,
чем отрицательных. Ответ: «Есть» или «Нет».
Если можно решите попроще, каждая отдельная операции через подпограмму



Вы находитесь на странице вопроса "роверить есть ли в заданном векторе А=а1,а2,, аn элементы равны нулю", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.