Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Найти количество едениц в двоичной записи заданного числа.

5-9 класс

Входные данные:
Во входном файле содержится единственное целое число n (0<=n<=2000000).
Выходные данные:
Выходной файл должен содержать одно число - количество двоичных едениц в записи числа n.
#| input.txt| output.txt|
1| 5| 2|
2| 16| 1|
3| 121| 5|

AdamThomas291 27 янв. 2014 г., 2:20:39 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Vcbfghdhftf
27 янв. 2014 г., 4:53:30 (10 лет назад)

var
  n: longint;
  k: integer;
  Fin, Fout: Text;

begin
  Assign(Fin, 'input.txt');
  Reset(Fin);
  Assign(Fout, 'output.txt');
  Rewrite(Fout);
  while not Eof(Fin) do
  begin
    Readln(Fin, n);
    k := 0;
    while n > 1 do
    begin
      k := k + (n mod 2);
      n := n div 2
    end;
    k := k + n;
    Writeln(Fout,k)
  end;
  Close(Fin);
  Close(Fout)
end.

Ответить

Другие вопросы из категории

5 5/12+4 7/18-6 2/9

P.S. Пять целых пять двенадцатых плюс четыре целых семь восемнадцатых минус шесть целых две девятых.
Надо срочно, буду благодарна :)

устройство ввода во время игры
Автосалон продает три модели «Lada»: Priora, Calina и Granta. Каждая из трех моделей может быть дооснащена любым количеством из двух дополнительных опций

(подогрев сидений и подогрев руля) или не оснащаться дополнительным оборудованием вовсе. Для каждой модели автомобиля и каждого набора опций выпускается прайс-лист. Один прайс-лист содержит базовую часть, содержащую информацию об одной модели «Lada» и дополнительную часть с каким-то набором опций. Тираж каждого прайс-листа практически неограничен и достаточен при любом наплыве посетителей. Посетителями салона являются только семейные пары. Муж и жена берут по одному прайс-листу по следующему правилу: базовая часть прайс-листов одинакова (семья заранее знает, какую модель «Lada» собирается купить), а дополнительная часть прайс-листов различна. В результате все семейные пары покидают салон, ничего не купив, но унося по паре прайс-листов. Чему равно наибольшее возможное количество семей, чьи пары прайс-листов различны?

Читайте также

1)сколько нулей в двоичной записи восьмеричного числа 34526107? 2)сравните два числа 100111 двоичный и 51 восмеричный 3)перевести в восьмеричную систему

счисления 110001000,1001 ДВОИЧНЫЙ 4)сколько единиц в двоичной записи шестнадцатеричного числа F523С? 5)сравните два числа 101111двоичный 47 восмиричный помогиииииииитеееее

решить через паскаль через массивы)) 1.Дан одномерный массив из 10 элементов. Заменить все большие 7 члены массива числом 7. Найти количество

таких членов.

2.Дан массив из 10 элементов. Найти количество элементов с четными индексами.

3.Дан массив из 10 элементов. Найти наибольший элемент массива.

Петя загадал последовательность из 4 чисел, в которой каждое следующее число на единицу больше предыдущего. После этого он записал каждое число в

системе счисления с определенным основанием, не меняя порядка чисел. Все числа записаны в системах счисления с разными основаниями. Получилась следующая запись:37 35 33 31Определите, в какой системе счисления записано последнее число, если известно, что одно из чисел записано в восьмеричной системе счисления. В ответе укажите натуральное число, равное основанию этой системы счисления.

Сколько единиц в

двоичной записи десятичного числа 194,5?



Вы находитесь на странице вопроса "Найти количество едениц в двоичной записи заданного числа.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.