Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Помогите решить на паскале

10-11 класс

______________________________________
В сказочном Солнечном городе живут трое братьев: Ниф-Ниф, Наф-Наф, и Нуф-Нуф. Известно, что у каждого из них есть какое-то количество денег. Так случилось, что после физкультуры они перепутали пиджаки, в которых и лежали деньги. Однако зная о возможной путанице родители пришили бирки с именами. Помогите определить сколько же денег было до физкультуры у братьев, зная что Нуф-Нуф пришел домой в пиджаке Ниф-Нифа, а Наф-Наф в пиджаке Нуф-Нуфа. Входные данные:

В единственной строке входного потока, через пробел записано три числа в диапазоне от 1 до 10^9. Первое число это количество денег, которое обнаружил Ниф-Ниф в карманах придя домой. Второе - сколько стало у Наф-Нафа. И третье сколько принес домой Нуф-Нуф.

Выходные данные:

В первую строку выходного потока необходимо вывести сколько денег было у Ниф-Нифа, во вторую - сколько у Наф-Нафа, а в третью - сколько у Нуф-Нуфа.

Пример входного файла (input.txt): 32 22 54 Пример выходного файла (output.txt): 54 32 22

Davtetbaev 10 июля 2014 г., 18:43:02 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Valyushka3337
10 июля 2014 г., 21:00:12 (9 лет назад)

var a,b,c:int64;
begin
read(a,b,c);
writeln(c);
writeln(a);
writeln(b);
end.

Ответить

Другие вопросы из категории

Сколько целых страниц машинописного текста можно записать на магнитную дискету (считая, что никакой информации, кроме собственного текста, в файле не

хранится и одна страница машинописного текста примерно занимает 2,5 Кбайт), если:
Ёмкость (объём) дискеты: 1,2 Мб
Строк на странице: 40
Символов с строке: 60

Помогите пожалуйста решить

Читайте также

Исполнитель Черепашка выполняет программу:

для K от 1 до N выполнить
вперёд K
направо 90
кц
Ввести N и определить расстояние между начальным и конечным положением исполнителя.
Помогите решить на паскале

ПОМОГИТЕ РЕШИТЬ, НА ЛАБЕ СИЖУ!!!

Определить делится ли на целое число х целое число у без остатка. Если делится, то разделить х на у и вывести его. В турбо паскале програмку написать.

Помогите решить в паскаль.

По древней легенде мудрец, который изобрел шахматы, потребовал от персидского шаха такое количество пшеницы, чтобы им можно было покрыть шахматную доску, положив на первую клетку 1 зерно, на вторую - 2, на третью - 4 и т.д., т.е. на каждую следующую в двое больше предыдущей. Каким количеством зерна можно покрыть шахматную доску?




Вы находитесь на странице вопроса "Помогите решить на паскале", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.