Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

составьте программу позволяющую удвоить каждый символ заданной строки и вывести полученную строку на экран

5-9 класс

3031978l 31 авг. 2015 г., 12:21:19 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Olegmolgavko
31 авг. 2015 г., 13:25:37 (8 лет назад)

var a,b:string;
i: integer;
begin
write('Введите строку: '); readln(a);
b:='';
for i:= 1 to length(a) do b:=b+a[i]+a[i];
write('Новая строка: ',b);
end.

Ответить

Другие вопросы из категории

В первый час работы рабочий изготавливает a деталей, за каждый последующий час - на d деталей больше, чем предыдущий. Разработайте программу, которая по

дсчитает, сколько деталей изготовил рабочий за 8 часов работы. Зафиксируйте свои действия на каждом из этапов решения этой задачи.
1-й этап
2-й этап
3-й этап
4-й этап
5-й этап

Читайте также

1)составьте программу ввода элементов массива а[1..8 ] с клавиатуры и вывода на экран элементов с отрицательными значениями; 2)составьте

программу ввода элементов массива b[1..6] с клавиатуры и вывода на экран элементов с положительными значемиями

1) составить программу , которая вычисляет суммы элементов столбцов двумерного массива и записывает их в одномерный

2-ая Составить программу , которая в двумерном массиве случайных чисел элементы всех четных строк делает нулевыми
язык паскаль

Составить программу, определяющую, является ли данное утверждение истинным:Двузначное число А начинается на 3

Составить программу, определяющую, является ли данное утверждение истинным:Ровно одно из чисел А и В не превышает 100

Составить программу в паскале: Для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие

результаты.:

· Если первое из них отрицательно, а второе вдвое больше третьего, то выведите среднее арифметическое всех четырех чисел.

· Если произведение этих чисел больше их суммы, то выведите эти сумму и произведение.

· Если выполняются одновременно два перечисленных выше условия, то выведите среднее арифметическое этих чисел, их произведение и сумму

· Иначе, выведите удвоенные значения этих чисел

1)напишите программу которая спрашивала бы название продукта и его цену. И затем на экран выводила фразу "Ваши расходы на покупки равны руб." 2) написать

программу, которая запрашивала три числа, подсчитывала их средне и сумму и на экран выводила фразу "Их среднее равно..." и "Их сумма равна..."



Вы находитесь на странице вопроса "составьте программу позволяющую удвоить каждый символ заданной строки и вывести полученную строку на экран", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.