Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Найти сумму всех n-значных чисел, кратных k (1 ≤ n ≤ 4).

5-9 класс

Кумир. Помогите, срочно надо!

Катя150603 06 июля 2016 г., 3:28:32 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ralinaahmadull
06 июля 2016 г., 5:43:15 (7 лет назад)

Я так понимаю вам нужна программа на Паскале
program zadacha;
var s,k,n,p,i:integer;
begin
s:=0;
p:=1;     
readln(n,k);     
for i:=1 to n do p:=p*10;     
for i:=trunc(p/10) to p-1 do     
if i mod k=0 then     s:=s+i;
write(s);
end.

+ 0 -
Cepkov123123
06 июля 2016 г., 7:41:25 (7 лет назад)

Комментарий удален

Ответить

Другие вопросы из категории

Помогите пожалуйста решить!!!!!!!!

даны две точки в плоской прямоугольной системе координат. Напишите программу, определяющую, которая из точек находится ближе к началу координат!!!
Пример входных данных
Координаты 1-й точки >>1 2
Координаты 2-й точки >> 3 4
1 ая точка ближе

Пожалуйста с примером!!!!заранее большое спасибо!!!!!

Объясните как делать В таблице Dat хранятся данные о количестве сделанных учениками заданий (Dat[1] – заданий сделал первый ученик Dat[2] –

второй ученик и т.д.). Определите, что будет напечатано в результате работы следующей программы.

Алгоритмический язык

алг

нач

целтаб Dat[1:10]

цел k, m

Dat[1]:=7; Dat[2]:=9

Dat[3]:=10; Dat[4]:=5

Dat[5]:=6; Dat[6]:=7

Dat[7]:=9; Dat[8]:=8

Dat[9]:=6; Dat[10]:=9

m:= 10

нц для k от 1 до 10

если Dat[k] < m то

m:=Dat[k]

все

кц

вывод m

кон

Вопрос на фото ниже ..........

Читайте также

1.С клавиатуры вводится 3 числа. Найти сумму только из положительных чисел.

(Тема:Программирование ветвлящихся и цепленных алгоритмов)
2.Дано двухзначное число,найти сумму и произведение его чисел.
(2-ая задача решается с div и mod)
(Тема:Программирование ветвлящихся и цепленных алгоритмов )

Написать программу в турбо паскаль.

Найти сумму всех n-значных чисел (1 ≤ n ≤ 4)

Найти сумму всех двух значных чисел

Плис, напишите программу на turbo pascal



Вы находитесь на странице вопроса "Найти сумму всех n-значных чисел, кратных k (1 ≤ n ≤ 4).", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.