Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

Написать программу: Вводятся N целых чисел. Подсчитать сумму тех из них, которые являются положительными.

5-9 класс

Паскаль АВС на английском

Kulikgalia83 03 окт. 2016 г., 20:54:24 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Алинчик21
03 окт. 2016 г., 23:48:14 (7 лет назад)

program sum_pol;
var i,n,k,sum:integer;
begin
readln(n); sum:=0;
for i:=1 to n do begin
read(k); if k>=0 then sum:=sum+k;
end;
write(sum);
end.

Ответить

Другие вопросы из категории

Аналоговый звуковой сигнал был дискретизирован сначала с использованием глубины

кодирования равной 8 бит, а затем с использованием глубины кодирования 16 бит. Во сколько
раз различаются информационные объемы оцифрованного звука?

Помогите ответить на вопросоС срочно.

Вопрос
Имя , обозначающее множество объектов?

Читайте также

ПОМОГИТЕЕЕЕ!!!:С Введите с клавиатуры 5 положительных чисел.Вычислите сумму тех из них,которые делятся на 4 и при этом заканчиваются на

6.Программа должна вывести одно число:сумму чисел,введенных с клавиатуры, кратных 4 и оканчивающихся на 6.

1)Вывести на экран квадраты и кубы нечётных целых чисел от 9 до 1.

2)Даны натуральные числа от 1 до 150. Найти сумму тех из них, которые делятся на 5 или на 7.
3)Напечатать те из чисел от 10 до 50, которые делятся на 4, но не делятся на 6
4)Найти произведение нечетных чисел от 10 до 50, кратных 13
кто может сделать в Паскале или просто решить?

Язык pascal ABC

Введите 5 положительных уныл чисел, вычислите сумму тех из них которые делятся на 4, и оканчиваются на 6. Если таких чисел нет, то вывести об этом сообщение.

Помогите пожалуйста ! срочно надо!!!...в заданной последовательности целых чисел определите сумму элементов кратных 10! пример задачки вот именно под

типо по такой же системе которую щас напишу! program Maximum; i,n,max:integen; begin writeln ( 'введи элементы массива для поиска максимума'); for i:=1 to 10 do begin write ('a [', i ,']=');readln (a [ i ] ) ;end; max:=a[1]; for i = 2 to 10 do if a [ i ] > max then begin max:=a [ i ] ; n:= i ; end; writeln ('найти наибольший элемент ',max ,' под номером ', n); вот наподобие этого примера нужно построить мою задачу! в заданной последовательности целых чисел определите сумму элементов кратных 10. Помогите пожалуйста!!!

Пожалуйста, помогите! Если я не сделаю это задание, мне придется сдавать сложнейший экзамен. Пожалуйста!

Написать программу ввода четырех целых чисел и вычисления их среднего арифметического. Протестировать программу на различных исходных данных (включая вещественные числа) и доказать правильность ее работы.



Вы находитесь на странице вопроса "Написать программу: Вводятся N целых чисел. Подсчитать сумму тех из них, которые являются положительными.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.