Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

помогите пажалуйста. очень надо решить!!!!! составьте программу, которая формирует массив из 40 случайных целых чисел от 0 до 20 и вычисляет

10-11 класс

среднее арифметическое нечётных чисел.

Irina6452 18 июля 2013 г., 17:38:57 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Sonya1234
18 июля 2013 г., 19:16:18 (10 лет назад)

var

a:array [1..40] of integer;

k,i,s:integer;

sr:real;

begin

randomize;

for i:=1 to 40 do begin

a[i]:=random(21);

write (a[i],' ');

end;

writeln;

for i:=1 to 40 do

if odd(i)=true then begin

k:=k+1;

s:=s+a[i];

end;

sr:=s/k;

writeln (sr:3:4);

readln;

end. 

Ответить

Другие вопросы из категории

Читайте также

Люди помогайте!!!))) Паскаль!!!

1)Составьте программу, которая заполняет массив 10-ю случайными целыми числами в диапазоне [1..20] и выводит на экран элементы массива в нечетными значениями.

2)Составьте программу заполнения массива из десяти чисел следующими значениями
а) 2 4 6 8 10 (+ 2)
б)3 6 9 12 15 (+3)

Напишите прог-у на паскале... ПЛИИИИИИИИИИЗ 1)даны действительные числа a1, b1, c1, a2, b2, c2. Составьте программу, которая находит координаты точки

пересечения прямых, описываемых уравнениями a1x+b1x=c1 и a2x+b2x=c2. Если прямые пересекаются или не существуют-выдать соответствующее сообщение. 2) даны действительные числа a1, b1, a2, b2. Составьте программу, которая определяет, какая из точек A(a1;b1) или B(a2;b2) лежит на прямой у=2х+1. Если такой точки нет-вывести соответсвующее сообщение.



Вы находитесь на странице вопроса "помогите пажалуйста. очень надо решить!!!!! составьте программу, которая формирует массив из 40 случайных целых чисел от 0 до 20 и вычисляет", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.