Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 975 ответов!

В линейном массиве сместить каждый положительный и четный по значению элемент на один назад. (Язык программирования - Паскаль)

10-11 класс

Slava542936 03 окт. 2014 г., 22:56:42 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
ПеченькО001
03 окт. 2014 г., 23:43:34 (9 лет назад)

var a:array[1..999999] of integer;
n,i,tmp:integer;
begin
readln(n);
for i:=1 to n do
  read(a[i]);
for i:=1 to n do
  if (a[i]>0) and (a[i] mod 2 = 0) then begin
    tmp:=a[i];
    a[i]:=a[i-1];
    a[i-1]:=tmp;
    end;
for i:=1 to n do
write(a[i],' ');
end.

+ 0 -
Aleksandr555777
04 окт. 2014 г., 0:49:01 (9 лет назад)


Смотрите во вложении................

+ 0 -
Alenkaaшекшл6ег
04 окт. 2014 г., 3:02:57 (9 лет назад)

т.е. поменять его местами каждый положительный четный и предыдущий?

+ 0 -
Gulyaev1
04 окт. 2014 г., 4:24:06 (9 лет назад)

Да

Ответить

Другие вопросы из категории

4 гигабайта перевести в байты с решением

2 терабайта в мегабайты

2^13 бита в килобайты

1.Составить программу, которая увеличивает каждый элемент настоящей таблице х [1 .. 10] на 1. 2. составить программу, замены положительных

элементов настоящей таблице х [1 .. 10] на 0.

3.составить программу, замены отрицательного элементов настоящей таблице х [1 .. 10] на их квадрат.

4.составить прогрумму, которая увеличивает на 2 все элементы настоящей таблице х [1 .. 10], которые больше 10.

Читайте также

1.Даны два массива: А(5) и В(5). Сформируйте из них массив С,предварительно определив его длину,включая попеременно из массива А положительные

элементы, а из массива В -нечетные по значению.Выведите на экран массивы А,В,С.

2.Информация о площадях и средней урожайности хранится в массиве,где каждый элемент с четным индексом - засеянная площадь, а с нечетным - урожайность.Определите и выведите на экран кол-во собранной пшеницы и среднюю урожайность.

Помогите пожалуйста!

Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом

массиве. Результаты сохранить в одномерном массиве и элементы массива отсортировать по возрастанию Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом массиве. Результаты сохранить в одномерном массиве и элементы массива отсортировать по возрастанию

ПАСКАЛЬ.1)дан целочисленный массив из 30 элементов.элементы массива могут принимать целые значения от 0 до 1000.опишите на русском языке или на одном из

языков программирования алгоритм,позволяющий найти среднее арифметическое нечетных трехзначных чисел,записанных в этом массиве.если ни одного такого числа нет,нужно вывести сообщение об этом.
2)дан целочисленный массив из 30 элементов.элементы массива могут принимать целые значения от 0 до 100.опишите на русском языке или на одном из языков программирования алгоритм,позволяющий найти и вывести произведение элементов массива,которые имеют четное значение и не оканчиваются на 0.

Заполнить массив T размерностью M значениями, введенными с клавиатуры.

Вывести на экран в одну строку каждый 2 элемент массива, который больше заданного значения K. (Язык программирования - Паскаль)



Вы находитесь на странице вопроса "В линейном массиве сместить каждый положительный и четный по значению элемент на один назад. (Язык программирования - Паскаль)", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.