Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

В массиве записана стоимость каждого товара, продаваемого фирмой. Фирма прекратила продавать товары, стоимость которых равна значению, записанному в

10-11 класс

К-той ячейке массива. Определить какие товары продолжает продавать фирма.

Через Паскаль.

извините за кач-во ._.

Dina1093 27 дек. 2014 г., 11:24:25 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
КоротееваЮлия1998
27 дек. 2014 г., 12:53:03 (9 лет назад)

 

program MYPROG;

 

var

    goods: array[0..10] of string;

    prices:array[0..10] of real;

    number_of_goods:integer;    

    k:real;

    i:integer;

begin

  number_of_goods :=10;

  //Заполняем каким то образом названия товаров и цены к ним

  goods[0] := 'Дети';               prices[0] := 15;

  goods[1] := 'Женщины';     prices[2] := 10;

  goods[2] := 'Щеночки';       prices[3] := 150;

 

 readln(k);

 if (k>number_of_goods) or (k<0) then

     writeln('Out of range')

 else

 begin

       for i:=0 to number_of_goods do

           if prices[i]<>prices[k] then writeln(goods[k])

 end

 

end.

 

 

Вот примерно вот так

Ответить

Читайте также

Составить программу, которая формирует файл записей, содержащих информацию об автомобиле (название модели, год выпуска, цена, цвет), а также найти в

массиве записей и вывести на экран названия моделей красного цвета, випускалиcя в 2000 году.

P.s Помогите пожалуйста, заране огромное спасибо.

Задан одномерный массив А(N) (N<=60). На место минимального элемента массива записать сумму последних К элементов массива. Если А[1]>=0, то умножить

все элементы этого массива на квадрат минимального элемента данного вектора, а если А[1]<0, то умножить все элементы на квадрат максимального элемента вектора. Полученный массив распечатать. Значение К вводится пользователем.

1. Для записи текста, каждая страница которого состоит из 28 строк по 65 символов, использовался 16-символьный алфавит. Какой объем информации в Кбайтах

содержат 5 страниц текста?
2. На предприятии имеется 9 автомобилей ГАЗ, 1 автомобилей ЗИЛ, 9 автомобилей КаМАЗ, 4 автомобилей MAN. Какое количество информации несет сообщение о выезде с территории автомобиля каждого вида?



Вы находитесь на странице вопроса "В массиве записана стоимость каждого товара, продаваемого фирмой. Фирма прекратила продавать товары, стоимость которых равна значению, записанному в", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.