Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Напишите программы. Заранее спасибо!

5-9 класс

1) P:= 1*2*3....*N
2) S:= 100+95*90+...5

Tanucha098 21 февр. 2016 г., 9:31:39 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Eustas
21 февр. 2016 г., 12:25:15 (8 лет назад)

1)Это функция факториала числа 
readln(n);
I:=n;
 y:=1;    
while i>1 do
begin      
y:=y*i;                
i:=i-1;    
end;
2) ну вот по том что ты написал
 var    i,n:Integer;
begin   
i:=5;   
n:=0;
repeat 
n:=n+i; 
i:=i+5;
until i=100;
Writeln(n); 
readln;
end.

Ответить

Читайте также

Язык программирования Бейсик Здравствуйте. Кто может найти ошибку в моем решении задачи: "Напишите программу, которая находит кол-во

чисел, кратных 3, но не кратных 6, в последовательности заданных чисел. Программа получает на вход целые числа, кол-во введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (0 - признак окончания ввода, не входит в последовательность). Кол-во чисел не превышает 1000. Введенные числа по модулю не превышают 30000."

Решение:

10 CLS

20 FOR I=1 TO 1000

30 INPUT "Введите число";A(I)

40 IF A(I)=0 THEN M=I AND 60

50 NEXT I

60 FOR I=1 TO M

70 IF A(I) MOD 3 = 0 AND A(I) MOD 6 <>0 THEN S=S+1

80 NEXT I

0 PRINT S

100 END

Заранее спасибо

Помогите по программе paskal : 1.дано целое число.напишите программу которая уменьшает на 2 модуль этого числа и выводит на экран монитора

результат

2.дано целое число.напишите,программу которая выводит на экран последнюю цифру данного числа,затем возводит ее в квадрат и выводит на экран монитора результат

Пожалуйста помогите срочно. Напишите программу в паскале для 9класса отображающую третий закон Ньютона. Если не можете сюда кинуть, киньте на мой мейл -

[email protected] заранее спасибо

Даны три натуральных числа. Напишите программу, определяющую, существует ли треугольник с такими длинами сторон. Если существует, определите его тип

Имеются данные о количестве полных лет трех призеров спартакиады. Напишите программу, выбирающую и выводящую возраст самого младшего призера.

а)Одномерный массив A заполнен десятью случайными целыми числами от 1 до 20. Напишите программу вывода элементов массива в обратном порядке.

б)Напишите программу, которая массив из 20 элементов заполнит неповторяющимися целыми числами и выведет на экран элементы с нечетными индексами.



Вы находитесь на странице вопроса "Напишите программы. Заранее спасибо!", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.