Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 975 ответов!

Умоляю,помогите составить программу... С клавиатуры одной строкой вводят имя и фамилию через пробел.Составьте программу,которая проверяет,совпадает ли

10-11 класс

последний символ имени и предпоследний символ фамилии...

Asiasvyaznoy12 09 окт. 2014 г., 13:32:32 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Sk15071985
09 окт. 2014 г., 15:31:21 (9 лет назад)

Использовать латиницу

 

#include <iostream>
using std::cout;
using std::cin;
using std::endl;
#include <cstring>
using std::strlen;
using std::strtok;

int main()
{
    char s[100];
    char *temp1;
    char *temp2;

    cout << "Enter the name and surname: ";
    cin.getline(s, 100);

    temp1 = strtok(s, " ");
    temp2 = strtok(NULL, " ");

    if(*(temp1 + strlen(temp1) - 1) == *(temp2 + strlen(temp2) - 2))
    {
        cout << "true" << endl;
    }
    else
        cout << "false" << endl;

   return 0;
}

+ 0 -
Nkleen
09 окт. 2014 г., 17:41:25 (9 лет назад)

Var
s,fam,nam:string;
begin
writeln('Vvedite imy i familiy:');
readln(s);
nam:=copy(s,1,pos(' ',s)-1);
fam:=copy(s,pos(' ',s)+1,length(s));
if nam[length(nam)]=fam[length(fam)-1] then writeln('Sovpadayut') else writeln('Ne sovpadayut');

write('Dly vyhoda nagmite Enter');
readln;
end.

Ответить

Другие вопросы из категории

Эдика, Колю и Васю угостили печеньем 3-х сортов: с

вареньем, с орехами и глазурью. Вася не любит орехи, Эдик не ест
варенья, а Коля очень любит глазурь. Каждый ел печенье только
одного сорта. Кто ел печенье с вареньем?

Задание 2 Тема: Ряды (циклы, итерации). Операторы DO используются для организации цикл

ических расчетов.

Цикл - это последовательность операторов, которая может автоматически выполняться более одного раза. Если количество повторов известно заранее (или может быть однозначно вычислено), используется оператор Цикл_с_параметром (DO «UNTIL»). Если количество повторов неизвестно, применяется оператор Цикл_с_Пред_условием (DO «WHILE»).

Вычислить сумму ряда:

a) с заданной точностью ξ и вывести количество итераций;

b) для 20-ти членов ряда.

Σ = 1/(1*3) + 1/(3*5) + 1/(5*7) + … ξ=0.0001 Ответ: 0.500

Читайте также

помогите плз сделать домашку по информатике))) с клавиатуры одной строкой вводят имя и фамилию. Составьте программу, которая: а) определяет, есть ли во

введенной строке заданный символ б) копирует в новую строку имя и выводит его в) выводит сначала фамилию, а затем имя....

помогите составить программу!пожалуйста!!!!ооочень надо

ракета запускается с земли со скоростью V(км час) в направлении движения земли по орбите вокруг солнца. составить программу,определяющую результат запуска ракета в зависимости от скорости V.
Известно,что при V16,4 ракета покинет солнечную систему.



Вы находитесь на странице вопроса "Умоляю,помогите составить программу... С клавиатуры одной строкой вводят имя и фамилию через пробел.Составьте программу,которая проверяет,совпадает ли", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.