Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Помогите пожалуйста, что будет выведено на экран после выполнения программы for1:=1to 4 do

10-11 класс

write(i*2)

Pepelsu 28 янв. 2017 г., 5:39:11 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
BubblegumLadida
28 янв. 2017 г., 6:25:49 (7 лет назад)

for это цикл счетчик, то есть наверно команда будет так 
for i:=1 to 4 do write(i*2); а не for 1:=1 to 4 do
write это команда вывода. То есть команда write будет выведено 4 раза потому что счетчик у нас с 1 до 4.
Вместо i подставляем счетчик с 1 до 4.
Первый write(1*2)=2, 
Второй write(2*2)=4
Третий write(3*2)=6
Четвертый write(4*2)=8

+ 0 -
Antre7
28 янв. 2017 г., 7:18:43 (7 лет назад)

блин,срочно надо,горит уже:-(

Ответить

Другие вопросы из категории

Напишите кто что сможет
Составить программу расчета нормы внесения известкового удобрения (т/га) по формуле: Д=_______100* Н__________, где Н- полная норма

CaCO3 т/га, В- влажность

(100- В)*(100-К)*П

извести, %; К- количество недеятельных частиц%; П- нейтрализующая способность СаСО3,%.

полная норма СаСО3 изменяется в пределах от 2 до 4 т/га с шагом 0,1 т/га.

Пожалуйста, помогите написать программу или хотя бы объясните, что от меня вообще хотят....Найти количество элементов к каждому столбцу прямоугольной

вещественной матрицы, меньших среднего арифметического всех элементов, рассмотренного столбца.

Помогите пожалуйста с 3 и 4 заданиями!!!

Читайте также

Помогите с тестами по информатике!!! А1. Определите значение целочисленных переменных a и b после выполнения фрагмента программы:

a := 3 + 3*4;

b := (a div 10) + 4;

a := (b mod 10) + 2;

b:= a + b;

a:= a mod 2 + b div 3;

1) a=4, b=14;

2) a= 24, b= 6;

3) a=5, b=12;

4) a=8, b=12.

А2. Для какого из указанных значений числа X истинно высказывание

((X < 5)→(X < 3)) Ù ((X < 2)→(X < 1))

1) 1

2) 2

3) 3

4) 4

А3. Укажите, какое логическое выражение равносильно выражению ¬(A Ú ¬B Ú C) ?

1) ¬A Ú B Ú ¬C

2) A Ù ¬B Ù C

3) ¬A Ú ¬B Ú ¬C

4) ¬A Ù B Ù ¬C

X

Y

Z

F

1

1

1

1

1

1

0

1

1

0

1

1

А4. Символом F обозначено одно из указанных ниже логических выражений от трех аргументов: X, Y, Z. Дан фрагмент таблицы истинности выражения F (см. таблицу справа).

Какое выражение соответствует F?

1) X Ú ¬Y Ú Z

2) X Ù Y Ù Z

3) X Ù Y Ù ¬Z

4) ¬X Ú Y Ú ¬Z

А5. Что будет выведено на печать в результате выполнения следующих операторов:

a := 5; b := 10;

write( 'сумма двух чисел ' ); write( 'a+b' );

write( ' = ', a+b );

1) сумма двух чисел 5+10 = 15

2) сумма двух чисел a+b = 15

3) сумма двух чисел 5+10 = a+b

4) сумма двух чисел a+b = 5+10

5) ни один из ответов 1-4 не верен

А6. Чему было равно значение переменной a, если после выполнения операций

b := sqrt( sqr(a+1) );

c := -b;

a := 1 + 2 / (c-b);

она стала равна 0 ?

1) 2

2) 0

3) –1

4) любое вещ. число, не равное -1

5) ни один из ответов 1-4 не верен

А7. Чему будет равно значение А после выполнения цикла

а:=1024;

While a>0 do

a:=a / 2;

1) 0

2) 1

3) зациклится

4) 512

5) ни один из ответов 1-4 не верен

A8. Сколько раз выполнится тело цикла?

A:=32;

While A>2 do

Begin A:=A / 2; writeln(‘A’); end;

1) 8

2) 6

3) 5

4) 4

5) 3

1. Задайте массив из 10 элементов с помощью датчика целых случайных чисел. Найдите сумму четных элементов массива. Выведите на экран исходный массив и

полученную сумму.
2. Дан массив В(n). Определите произведение элементов, кратных 3. Выведите на экран исходный массив и найденное произведение.

Для пяти произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты. Если первое, второе и пятое числа отрицательны, то

выведите их произведение. Если третье и четвёртое числа больше100, то выведите среднее арифметическое всех пяти чисел. Если выполняются одновременно два перечисленных выше условия, то выведите на экран все пять чисел без изменения. Иначе, выведите третье и пятое числа, увеличив их в два раза.

Что будет выведено на экран в результате выполнения следующих действий?

K:=0;
For A:=1 to 5 do
Begin
K:=K+A;
Write(K);
End.

10 КЛАСС! ПАСКАЛЬ АБС!! СРОЧНО!! ПОМОГИТЕ ПОЖАЛУЙСТА! Дан массив А(n). Опередлите кол-во нечет элементов массиава, стоящих на

четных местах. выведите на экран исходный массив и найденное кол-во.



Вы находитесь на странице вопроса "Помогите пожалуйста, что будет выведено на экран после выполнения программы for1:=1to 4 do", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.