Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

Дан массив, состоящий из 100 целых чисел:

10-11 класс

а) Вывести все числа, которые встречаются в этом массиве по нескольку раз;
б) Вывести все числа, которые встречаются в массиве только по одному разу.

Alya107 20 мая 2013 г., 8:36:13 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Medli
20 мая 2013 г., 10:47:10 (10 лет назад)

Dim A(100) As Integer, Odin As Boolean
Dim k As Integer , i As Integer
Randomize
For i = 1 To 100
A(i) = Int(Rnd*100) + 1 ' Заполняем массив случайными числами от 1 до 100
Print A(i) & CHR(9); ' Выводим начальный массив через табуляцию
Next i
Print "Повторяющиеся элементы"
For i = 1 To 100
For k = i+1 To 100
If A(i) = A(k) Then Print A(i) & CHR(9);
Next k
Next i
Print "Не повторяющиеся элементы"
For i = 1 To 100
Odin = True 
For k = i+1 To 100
If A(i) = A(k) Then Odin = False
Next k
If Odin = True Then  Print A(i) & CHR(9);
Next i
End

Ответить

Другие вопросы из категории

Напишите кто что сможет
Составить программу расчета нормы внесения известкового удобрения (т/га) по формуле: Д=_______100* Н__________, где Н- полная норма

CaCO3 т/га, В- влажность

(100- В)*(100-К)*П

извести, %; К- количество недеятельных частиц%; П- нейтрализующая способность СаСО3,%.

полная норма СаСО3 изменяется в пределах от 2 до 4 т/га с шагом 0,1 т/га.

Пожалуйста, помогите написать программу или хотя бы объясните, что от меня вообще хотят....Найти количество элементов к каждому столбцу прямоугольной

вещественной матрицы, меньших среднего арифметического всех элементов, рассмотренного столбца.

Читайте также

Паскаль помогите пжл!!!!!! Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива,

расположенных между максимальным и минимальным элементами.

Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива, расположенных между максимальным по модулю и минимальным по модулю элементами

ну или исправьте мое пжл

program fgf;
var mas:array[1..100] of real;
max,min:real;
i,n,c,b:shortint;
p:real;
f1,g:text;
begin;
assign (f1, 'input.txt');
reset (f1);
readln (f1, n);

for i:=1 to N do read (mas[i]);
max:=mas[i];
for i:=2 to N do begin
if mas[i]>max then begin
max:=mas[i];
c:=i;
end;
end;
min:=mas[1];
for i:=2 to N do begin
if mas[i]<min then begin
max:=mas[i];
b:=i;
end;
end;
close(f1);
assign (g, 'output.txt');
rewrite (g);
p:=1;
if b<c then I:=b+1 and c-1

else for I:=c+1 to b-1 do p:=p*mas[i];

if (n<3) or (b+1=c) or (c+1=b) then writeln(g,'0.00') else write(p:3:3) ;

close (g);
end.

Составить блок-схему решения задачи:

Дан массив, состоящий из 10 произвольных чисел. Найти среднее геометрическое этих чисел.

1. Пользователем вводится целое число. Вывести на экран последовательность целых чисел от единицы до этого числа.

2.Вывести на экран 10 строк, содержащие символ *, причем количество * в каждой строке должно быть равно номеру строки.
3.Пользователем вводится 2 целых числа. Вывести на экран сумму положительных четных чисел, находящихся в границах диапазона, указанного пользователем.
4. В результате работы программы формируется массив, состоящий из 10 элементов и заполненный случайными числами от 0 до 100. Вывести на экран этот же массив в порядке возрастания.
5.Вводится строка, содержащая буквы и цифры разного регистра (т.е. строчные и прописные буквы). В результате работы программы на экран выводится строка следующего вида: цифры в порядке возрастания, строчные буквы по алфавиту, прописные буквы по алфавиту.

на языке паскаль 1)дан массив натуральных чисел найдите сумму всех его элементов 2)вычислить количество положительных чисел

среди 10 элементов вещественного массива

3)заполнить массив из n целых чисел.выяснить какое число встречается раньше-положительное или отрицательное.

4)в целочисленном массиве есть отрицательные элементы.вывести номера этих элементов



Вы находитесь на странице вопроса "Дан массив, состоящий из 100 целых чисел:", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.