Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

1) Дан

5-9 класс

целочисленный массив из 30 элементов. Элементы массива могут принимать значения
от

0 до 1000. Опишите на русском языке или на одном из языков программирования
алгоритм, который находит и выводит среднее арифметическое всех элементов
массива, имеющих нечётное значение. Гарантируется, что хотя бы один такое
элемент в массиве есть.

Machnev1464 30 июня 2013 г., 3:23:53 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Александр22897
30 июня 2013 г., 5:36:01 (10 лет назад)

я бы сделал иначе

for i:= 1 to N do
Begin
    if A[i] mod 2 = 1 then
    Begin
        x:=x+1;
        y:=y+A[i];
    End;
End;
S = y/x;
WriteLn(S);

немного логичнее.

+ 0 -
Reportt
30 июня 2013 г., 7:04:10 (10 лет назад)

Комментарий удален

Ответить

Другие вопросы из категории

напишите дано.

Подсчитать в килобайтах количество информации в тексте,если текст состоит из 800 символов, а мощность используемого алфавита -128 символов.(8 класс)помогите пожалуйста срочно надо!!!

Читайте также

Помогите по программе paskal : 1.дано целое число.напишите программу которая уменьшает на 2 модуль этого числа и выводит на экран монитора

результат

2.дано целое число.напишите,программу которая выводит на экран последнюю цифру данного числа,затем возводит ее в квадрат и выводит на экран монитора результат

1). Дан массив из n элементов (n >= 4). Подсчитать среднюю арифметическую второго и предпоследнего элемента массива.

2). Дан массив из n элементов. Написать программу подсчитывающую произведение элементов массива.

Даны сведения о девяти крупнейших (по общей протяженности линий) метрополитенах мира.

Город.
1-Гуанчжоу
2-Лондон
3-Мадрид
4-Москва
5-Нью-Йорк
6-Пекин
7-Сеул
8-Токио
9-Шанхай
Кол-во пассажиров в год (млн.чел.)
1-2000
2-1200
3-600
4-2500
5-1700
6-3200
7-2600
9-3100
8-2500
Общая протяженность линий (км)
1-260
2-402
3-324
4-325
5-373
6-465
7-327
8-310
9-538
Загруженность (млн чел./км)
1-7,69
4-7,69
5-4,56
6-6,88
9-4,65
Задание: в каком из девяти данных городов загруженность метрополитена самая низкая?
Чему она равна? Ответ округли те до сотых.

вам предложили заменить телефон 1 на телефон 2. данные устройства обладают приблизительно одинаковыми техническими характеристиками, набором сервисов.

в телефоне 1 накоплено немало мультимедиа информации на дополнительном чипе памяти. выбери правильное и наиболее простое средство передачи информации в телефон 2.

1)Wi-Fi канал

2) система мобильной передачи данных

3) GPS система обмена данными

4) карта оперативной памяти micro SD. помогите пожалуйста....

Помогите пожалуйста Решить 2 задачи на языке Паскаль! 1) По данному числу N распечатайте все целые степени двойки, не

превосходящие N, в порядке возрастания.

Операцией возведения в степень пользоваться нельзя!

2)

В первый день спортсмен пробежал x километров, а затем он каждый день увеличивал пробег на 10% от предыдущего значения. По данному числу y определите номер дня, на который пробег спортсмена составит не менее y километров.

Программа получает на вход действительные числа x и y и должна вывести одно натуральное число.



Вы находитесь на странице вопроса "1) Дан", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.