Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

1. ЦИКЛ for на языке Pascal ABC

10-11 класс

SanchoPaNcHo14763 18 марта 2014 г., 5:47:58 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Zoyayurkova
18 марта 2014 г., 6:18:35 (10 лет назад)

Program TaskC;
Var i, il: Integer;
Begin
For i := 1 To 21 Do
If i Mod 2 = 1 Then
Write(i, ' ');
i := i + 1;
End;
ReadLn;
End.

Program TaskD;
Var i: Integer;
Begin
For i := 1 To 11 Do
Write(i * 2, ' ');
End;
ReadLn;
End.

Program TaskE;
Var i: Integer;
Begin
For i := 10 DownTo 1 Do
Write(i, ' ');
ReadLn;
End.

Program TaskF;
Var i: Integer;
Begin
For i := 10 DownTo 1 Do
Begin
Write(i * 10, ' ');
End;
ReadLn;
End.

Program TaskG;
Var i, sum: Integer;
Begin
For i := 1 To 10 Do
sum := sum + i;
WriteLn(sum);
ReadLn;
End.

Program TaskH;
Var i, product: Integer;
Begin
product := 1;
For i := 1 To 5 Do
product := product * i;
WriteLn(product);
ReadLn;
End.

Program TaskI;
Var i, sum: Integer;
Begin
For i := -5 To 5 Do
sum := sum + Abs(i);
WriteLn(sum);
ReadLn;
End.

Program TaskJ;
Var c: Char;
Begin
For c := 'A' To 'Z' Do
Write(c, ' ');
ReadLn;
End.

+ 0 -
Cerber37
18 марта 2014 г., 8:15:48 (10 лет назад)

Можно всё в одной программе написать?

+ 0 -
Rystam05
18 марта 2014 г., 9:31:39 (10 лет назад)

с-j осталось решить, желательно в разных, начиная с вара до енда:)

+ 0 -
Kik77
18 марта 2014 г., 12:07:01 (10 лет назад)

По одному буду добавлять окей?

+ 0 -
Smagulovalyucy
18 марта 2014 г., 14:33:23 (10 лет назад)

ок)

Ответить

Другие вопросы из категории

Найдите наименьшее K, такое что K! делится на N без остатка. K!=1*2*3...*(K-1)*K

Форма входа данных : в первой и единственной строке дано число N (1= Формат выходных данных: Выведите наименьшее число K факториал которого делится на N.

Примеры A.in = 4 A.out = 4 A.in = 8 A.out = 4

Сколько бит составляет 1,5 мб
Выберите неверные продолжения фразы. Скроллинг - это...

а) удаление фрагмента текста
б) копирование фрагмента рисунка в буфер обмена
в) работа со служебными программами
г) форма представления информации, при которой содержимое двигается в вертикальном или горизонтальном направлении

Имя Начинается на Е, фамилия на Ф

Помогите пожалуйста

Читайте также

Напишите на языках Pascal и C++ программу, которая генерирует 2 случайных вещественных числа и вычисляет их сумму, разность, произведение и

частное. Напишите на языках Pascal и C++ программу, моделирующую выбор одной из костей домино ( в наборе 28 костей домино, каждая состоит из двух половин, на каждой половине – от 0 до 6 очков). С помощью этой программы ответьте на вопрос: какова вероятность того, что выпадет кость с числом очков, кратным 3

Сделать следущие задачи на языке pascal abc

#2. Ввести В. Если В<10, выдать на печать 2*В. Если В>=10, вычислить и напечатать значения функции y=x²-x+tg(1/B+x) для значений x, изменяющихся от –3 до 1, с шагом 0,1.
#3. Ввести массив целых чисел Х(n). Найти среднее арифметическое значений элементов массива, не принадлежащих интервалу [-2;2]. Если среднее арифметическое значение>2, заменить значения первого и последнего элементов на 1, в ином случае – на 0. Массив распечатать.
#4. Ввести массив А(n). Найти сумму положительных элементов массива, исключая при этом те элементы, которые кратны трём. Полученной суммой заменить элементы 2-ой половины массива. Массив отпечатать.

В языке Pascal есть функция Pandom (a), которая служит для получения случайного ряда чисел из интервала (0;а). Вопрос: придумать, как можно при помощи

формул языка Pascal сделать так, чтобы случайные числа выпадали в интервале (a;b)

3. Не используя функцию возведения в квадрат, напишите на языке Паскаль наиболее короткие алгоритмы вычисления а) y=x¹° б)y=x¹⁵ или а) y=x^10

б)y=x^15

Постараться использовать минимальное количество дополнительных переменных.

4. Запишите на языке Паскаль программу циклического обмена значениями трёх переменных a,b,c. Схема циклического обмена: a ← b ← c. Например, если до обмена было: a=1, b=2, c=3, то после обмена должно стать: a=2, b=3, c=1.

1) Напишите пожалуйста программу (на языке BASIC) вычисления по длинам двух сторон треугольника и углу между ними длины третьей стороны и двух других

углов.
2)
Напишите пожалуйста программу (на языке BASIC) для определения подобия:
а) двух прямоугольников по двум смежным сторонам;
б) двух треугольников по трем сторонам.



Вы находитесь на странице вопроса "1. ЦИКЛ for на языке Pascal ABC", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.