Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 975 ответов!

Написать на Паскале программу, которая запрашивает с клавиатуры N произвольных целых чисел и ищет их сумму. Число N вводится с клавиатуры. Разработать для

5-9 класс

созданной программы не менее трех тестов и проверить на них правильность работы алгоритма.
БЕЗ МАССИВА
ПОЖАЛУЙСТА
+194884839383948 К КАРМЕ ТОМУ КТОНАПИШЕТ

Masichka1a 07 авг. 2014 г., 18:07:41 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Kipralin
07 авг. 2014 г., 20:35:47 (9 лет назад)

var i,n,s:integer;
begin
 write('Write N: ');
 readln(n);
 s:=0;   
for i:=1 to n do 
begin     
Readln(n);     
s:=s+n;   
end;   
writeln('Summ: ',s); 
readln;
end.

+ 0 -
вован231
07 авг. 2014 г., 23:14:30 (9 лет назад)

ИСПОЛЬЗУЯ WHILE

+ 0 -
Esfirsm
08 авг. 2014 г., 0:04:15 (9 лет назад)

var i,n,s,j:integer;
begin
write('Write N: ');
readln(n);
s:=0;
i:=0;
while i<=n-1 do
begin
Inc(i);
Readln(j);
s:=s+j;
end;
writeln('Summ: ',s);
readln;
end.

Ответить

Другие вопросы из категории

У Инфознайки беспорядок в папке с лабораторными работами. Для работы он использует программу «Проводник». Помоги ему быстро переименовать лабораторные

работы по порядку, чтобы получилось «Лабораторная работа (1)», «Лабораторная работа (2)», и т.д.

Читайте также

1)напишите программу которая спрашивала бы название продукта и его цену. И затем на экран выводила фразу "Ваши расходы на покупки равны руб." 2) написать

программу, которая запрашивала три числа, подсчитывала их средне и сумму и на экран выводила фразу "Их среднее равно..." и "Их сумма равна..."

Помогите решить задачки на паскале я совсем не разбираюсь в этом!!! 1)Дана таблица со значениями среднемесячных температур в течение года. Составить

программу на Паскале, в которой вычисляются четыре величины: средние температуры зимних месяцев, весенних месяцев, летних и осенних. 2)Вы посетили магазин и купили 10 видов товара. В таблицу T [1..10] записали количество купленного товара каждого вида. В таблицу C [1..10] записали цену единицы каждого вида товара соответственно. Составить программу на Паскале вычисления общей стоимости всех покупок.



Вы находитесь на странице вопроса "Написать на Паскале программу, которая запрашивает с клавиатуры N произвольных целых чисел и ищет их сумму. Число N вводится с клавиатуры. Разработать для", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.