Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Найдите пожалуйста ошибку

10-11 класс

mas2;
var
i,j,sum,kol:integer;
a: array [1..5, 1..5] of integer;
function rs (var kol:integer): integer;
var sum:integer;
begin
sum:=0;
kol:=0;
for i:=1 to 5 do
for j:=1 to 5 do
if (A[i,j]>0) and (j>i) then
begin inc(kol); sum:=sum+A[i,j]; end;
rs:=sum;
end;
begin
for i:=1 to 5 do
for j:=1 to 5 do
A[i,j]:= Random (9);
for i:=1 to 5 do
begin
for j:=1 to 5 do
write(A[i,j]:2);
writeln;
end;
writeln;
sum:=rs(kol);
writeln('Сумма= ',sum);
writeln('Количество=',kol);
readln;
end.

кутеповаив 03 марта 2017 г., 7:24:35 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Missyou8
03 марта 2017 г., 9:19:52 (7 лет назад)

Из далека вижу уже :))

Ответить

Другие вопросы из категории

Выполнить

действия над массивами. В таблице при формулировании задания для разъяснения
его сути справа отображены примеры исходных X и результирующих Y массивов с
конкретными числами. Программа, естественно, должна обрабатывать любые числа для
массивов произвольной размерности N.
Программа должна предъявлять исходные и новые (если требуется) массивы.

ПОМОГИТЕ!!!!

Основные параметры электронных таблиц?

Сформировать массив из 25 элементов, заполненный случайными числами. В первой половине массива увеличить четные элементы в два раза, а во второй

половине разместить элементы в порядке убывания. Вывести на экран начальный и итоговый массив. ( Pascal ABC )

1. Написать программу для паскаль, которая распечатывает таблицу умножения от 1 до 5.

2. Написать программу для пакаль, которая распечатывает таблицу умножения нечетных чисел от 1 до 9 на четные от 2 до 8.

Читайте также

30 пунктов!!!Паскль.найдите ошибку и объясните, пожалуйста!!умоляю, ребят!

Подсказка: ошибка связана с "writeln"

Ошибка времени выполнения: Входная строка имела неверный формат

Написал программу:

var
f1,f2:text;
d,s,z,n:longword;
a,b,t,m,x:smallint;
begin
assign(f1,'input.txt');
reset(f1);
assign(f2,'output.txt');
rewrite(f2);
readln(f1,d,a,b,s,t);
if a>b then x:=a-b else x:=b-a;
if d mod s=0 then n:=d div s else n:=d div s+1;
if x mod t=0 then m:=x div t else m:=x div t+1;
z:=n+m;
write(f2,z);
close(f1);
close(f2);
end.

Выдает ошибку: Ошибка времени выполнения: Входная строка имела неверный формат.
Где выдает ошибку: readln(f1,d,a,b,s,t);

ПОМОГИТЕ пожалуйста!!!

Пожалуйста помогите найти текст про садовые цветы(растения)

срочно пожалуйста!!!!!!1
срочно!

Ребятки, помогите пожалуйста! Нужно решить задачку с помощью программирования языка Паскаля

Найдите любое трёхзначное число, кратное заданному P и не равное ему.



Вы находитесь на странице вопроса "Найдите пожалуйста ошибку", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.