Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Найти значение функции f(k)/k для каждого k=2,3,...N где f(k) - кол-во простых чисел от 2 до k. Решить на паскале или на псевдокоде. Ну или хотя

10-11 класс

бы объясните алгоритм.

199920132014 29 мая 2013 г., 1:48:37 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
шоf
29 мая 2013 г., 4:04:31 (10 лет назад)

var k,n:word;

function f(x:word):word;
var n,i,j:word;
begin
n:=0;
for i:=2 to x do
for j:=2 to i do
if i mod j = 0 then
if i<>j then break else inc(n);
f:=n;
end;

begin
write('Введите n = ');readln(n);
for k:=2 to n do
writeln(k-1,' = ',(f(k)/k):0:2);
end.

Ответить

Другие вопросы из категории

----------------------------- СРОЧНО --------------------- Необходимо составить программу в pascal ABC с использованием рекурсии под инвертированием

понимают перестановку первого и последнего элементов этой части, второго и предпоследнего и т.д. а вот само задание ==> Инвертировать часть массива, расположенную между самым левым минимальным в первой половине массива и самым правым максимальным во второй половине массива.

Будьте любезны мне помочь...

Дисковое пространство используется при распределении памяти:
(нужно ответить на несколько вариантов ответа)


1. Фиксированными разделами

2. Страничном распределении

3. Разделами переменной величины

4. Сегментном распределении

5. Перемещаемыми разделами

Читайте также

№1. Дан массив из 30-ти элементов. Каждый элемент может принимать целочисленные значения от 0 до 100. Напишите программу, которая позволит найти сумму

двузначных элементов массива, которые не оканчиваются на 3. №2. Дан массив из 100 элементов. Каждый элемент может принимать целочисленные значения от 1 до 500. Напишите программу, которая позволит найти и вывести минимальное значение среди элементов массива, которые делят максимальное значение элементов массива без остатка.

помогите решить пожалуйста. по паскалю 1. а) вычисления значения функции у = 7х2 - 3х + 6 при любом значении х;

б) вычисления значения функции х = 12а2 + 7а — 16 при любом значении а.

2.

даны катеты прямоугольного треугольника. Найти его гипотенузу

Реализовать вычисление значений функции y(x) с использованием условия (если_то_иначе). При необходимости воспользуйтесь справочной информацией.

Значения параметра х (по одному значению для каждого промежутка) задать самостоятельно.

№1. Дан массив из 30-ти элементов. Каждый элемент может принимать целочисленные значения от -100 до 100. Напишите программу, которая позволит

подсчитать среднее арифметическое положительных элементов массива, которые кратны первому элементу массива. №2. Дан массив из 40 элементов. Каждый элемент может принимать целочисленные значения от 0 до 200. Напишите программу, которая позволит найти наиболее часто встречающийся элемент массива

Составить блок-схему и написать программу для решения задачи. Организовать вычисление значения функции y по формуле y=4x+3/x-1 -√2x+9 для любого заданного

значения аргумента x. Учесть вывод сообщения о невозможности вычисления значения функции



Вы находитесь на странице вопроса "Найти значение функции f(k)/k для каждого k=2,3,...N где f(k) - кол-во простых чисел от 2 до k. Решить на паскале или на псевдокоде. Ну или хотя", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.