Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Помогите пожалуйста!

10-11 класс

массив целых чисел из 10 элементов заполнить случайным образом. упорядочить массив по возрастанию. подсчитать количество и произведение элементов массива, больших 20 и меньших 50, вывести полученный результат

кармелита37 11 нояб. 2013 г., 23:01:32 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Alexrolex
12 нояб. 2013 г., 1:02:17 (10 лет назад)

const n = 10;

var
  a :array [1..n] of integer;
  i, j, k, kol, p :integer;

begin

  randomize;
  for i:= 1 to n do
    a[i]:= random(100);
   
  for i:= 1 to n-1 do
    for j:= 1 to n-i do
      if a[j] > a[j+1] then
      begin
        k:= a[j];
        a[j]:= a[j+1];
        a[j+1]:= k;
      end;
 
  kol:= 0; p:= 1;
  for i:= 1 to n do
    if (a[i] > 20) and (a[i] < 50) then
    begin
      inc(kol);
      p:= p * a[i];
    end;
   
  writeln(kol,'   ',p);

end.

+ 0 -
Dashaob04
12 нояб. 2013 г., 5:29:40 (10 лет назад)

спасибо большое))))

Ответить

Другие вопросы из категории

ПОЖАЛУЙСТА! НУЖНА ПОМОЩЬ!!!!

Дана матрица А (4, 5)
2, 3, -5, -10, 7
4, -10, -3, 2, 4
5, -2, -7, 11, -13
18, 19, -2, -4, -7
Из нее образовать две матрицы: в одной оставить все отрицательные элементы матрицы А (на месте положительных элементов поставить ноль), в другой оставить все положительные элементы (на месте отрицательных поставить ноль).
НАПИСАТЬ ПРОГРАММУ в VBA excel и скинуть сюда документом

Читайте также

Помогите пожалуйста.

Требуется написать Блокнот на делфи.
Написал всё, кроме кнопки "Сохранить" не пойму как сделать так, что бы при нажатии она работала как и в блакноте обычном.
Помогите пожалуйста :)

ПОМОГИТЕ, ПОЖАЛУЙСТА, ПРОСТО РАЗЪЯСНИВ ЗАДАНИЕ. ПЖЛ)))

.................................................................................................................................
Возьмите прайс лист любого компьютерного магазина или скачайте в интернете;
Составьте конфигурацию компьютера для специалиста вашей профессии;
Подберите программное обеспечение, поясните, для каких целей будут служить данные программы;
Посчитайте общую стоимость данной конфигурации по прайс листу
....................................................................................................................................
Учусь я на бухгалтера-экономиста.
Давайте думать вместе) Допустим, "специалист вашей профессии" - это бухгалтер. Я беру прайс лист (т.е. лист, где написаны наименования и цены всех товаров). Что такое конфигурация? Как её составить по этому прайс листу, если там и так всего цена и наименования известны...?)))) ПО подобрать, допустим, это будет ;MS Office Excel; для создания таблиц, а для данной задачи для подсчёта общей стоимости конфигурации; и ;MS Office World; для писания отчётов. Что же такое эти "конфигурации"?)))
Помогите, пожалуйста) не пропускайте вопрос)

Помогите, пожалуйста, составить алгоритм для следующей задачи: Вводятся четыре числа. Известно, что 3 из них равны, а 4-ое отличается от 3-ех других.

Нужно выдать число, которое отличается от других равных, при этом, используя ровно две операции сравнения. Я пытался решить эту задачу и через максимум-минимум, и через условия, но везде натыкался на грабли. Помогите, пожалуйста, разобраться. Заранее благодарю! Перед выставлением решения, рассмотрите следующие варианты: "2 4 4 4", "2 3 2 2 ", "-3 -3 -2 -3", "-4 -4 -4 -5".

Помогите, пожалуйста, разобраться и составить верный алгоритм. В задаче требовалось написать программу на Паскале и сравнить её с приведенной в учебнике.

"Подсчитайте кол-во операций в приведенном алгоритме (Ответ приведите в виде функции от параметра n)." Подсчитать кол-во операций самому - это возможно, а как привести ответ в виде функции от параметра n - я не знаю. Помогите, пожалуйста, понять это задание. Заранее благодарен!

Помогите пожалуйста!) Напечатать программу в паскале......

Пожалуйста...Срочно...Завтра крайний срок сдачи...Помогите...

Дан массив строк без пробелов. Напечатать строки, вторая половина которых не содержит цифры.



Вы находитесь на странице вопроса "Помогите пожалуйста!", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.