Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

ТЕМА: ЦИКЛИЧЕСКИЕ АЛГОРИТМЫ; ДАНЫ ЧИСЛА НА ОТРЕЗКЕ ОТ -5 ДО 5. НАЙТИ СУММУ ОТРИЦАТЕЛЬНЫХ ЧИСЕЛ ПРОИЗВЕДЕНИЕ ПОЛОЖИТЕЛЬНЫХ ЧИСЕЛ ДАННОГО ОТРЕЗКА.

5-9 класс

Boykov02 14 апр. 2014 г., 19:38:20 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Dashgazizovva
14 апр. 2014 г., 22:11:06 (10 лет назад)

Var sum,pr,i:integer;
Begin
pr:=1; 
   for i:=-5 to 5 do begin       
     if (i>0) then pr:=pr*i         
        else sum:=sum+i;           
            end; 
  Writeln('Сумма отрицательных чисел = ',sum);
  Writeln(''Произведение положительных чисел = ',pr);
End.

+ 0 -
1alisa1katunceva1
14 апр. 2014 г., 23:47:45 (10 лет назад)

А какая разница? Скажи лучше что незнаешь? как решать?

+ 0 -
Тусовщица
15 апр. 2014 г., 1:14:01 (10 лет назад)

разница в том, что никто не будет такое решать, обычно на капс локе пишут неадекваты и спамеры

+ 0 -
Claw04
15 апр. 2014 г., 3:13:34 (10 лет назад)

Ну мне как видишь помогли как бы я не писал, главное что текст понятен читающим.

+ 0 -
Lenaramble
15 апр. 2014 г., 5:52:50 (10 лет назад)

Ха это ты спасибо))

+ 0 -
Tatka5
15 апр. 2014 г., 6:29:19 (10 лет назад)

Не думаю, что главное, чтобы текст был понятен, главное чтобы его было приятно читать

Ответить

Читайте также

1)Составьте программу,которая заполняет массив e[1..11] случайными целыми числами в диапазоне от -15 до 1 и находит количество элементов кратных 5.

2)Составьте программу,которая заполняет массив e[1..8] случайными целыми числами в диапазоне от 1 до 20 и находит сумму элементов с нечётными значениями и количество элементов кратных 3.
3)Составьте программу,которая заполняет массив e[1..14] случайными целыми числами в диапазоне от -10 до 10,затем изменяет знак положительных элементов на противоположный,а отрицательные элементы заменяет на 0.Спасибо.

4 а) составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 , затем элементы с четными индексами

удваиваются , а элементы с нечетными индексами утраивает.Выведите на экран исходный и полученный массив.

б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 , затем изменяет знак элементов с четными индексами на противоположный .Выведите на экран исходный и полученный массивы.

5) а)составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит количество элементов ,которые больше своего соседа слева

б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 и находит количество пар элементов с четными значениями.

6) а)составьте программу ,которая заполняет массив а[1..20 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит среднее арифметическое элементов с четными значениями и нечетными индексами.

б) составьте программу ,которая заполняет массив b[1..15 ] случайными целыми числами в диапозоне от 1 до 20 и выводит все тройки элементов , упорядоченные строго по возрастанию.

1)Составте программуб которая заполняет массив а[1..10] случайными целыми числами в диапозоне от 1 до 10,затем преобразовывает его,увеличивая все

элементы с четными значениями на 1. Если элементы с чётными значениями отсутствуют, оставить массив без изменений.

2) Составте программуб которая заполняет массив а[1..10] случайными целыми числами в диапозоне от 1 до 10,затем преобразовывает его,увеличивая все элементы с нечётными значениями в три раза,а элементы с чётными значениями заменяя на 0.

Составьте программу (в Pascal) "Угадай". Программа задумывает случайное число в диапазоне от 0 до 99.

Программа задумывает случайное число в диапазоне от 0 до 99. После каждой попытки играющего прога выводит сообщение "больше", "меньше", "угадано". Дается 10 попыток. Программа завершается, если дан правильный ответ или попытки закончились.

4 а) составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 , затем элементы с четными индексами

удваиваются , а элементы с нечетными индексами утраивает.Выведите на экран исходный и полученный массив.
б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 , затем изменяет знак элементов с четными индексами на противоположный .Выведите на экран исходный и полученный массивы.
5) а)составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит количество элементов ,которые больше своего соседа слева
б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 и находит количество пар элементов с четными значениями.
6) а)составьте программу ,которая заполняет массив а[1..20 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит среднее арифметическое элементов с четными значениями и нечетными индексами.
б) составьте программу ,которая заполняет массив b[1..15 ] случайными целыми числами в диапозоне от 1 до 20 и выводит все тройки элементов , упорядоченные строго по возрастанию.
напишите хоть какое нибудь нужно к завтрому срочно



Вы находитесь на странице вопроса "ТЕМА: ЦИКЛИЧЕСКИЕ АЛГОРИТМЫ; ДАНЫ ЧИСЛА НА ОТРЕЗКЕ ОТ -5 ДО 5. НАЙТИ СУММУ ОТРИЦАТЕЛЬНЫХ ЧИСЕЛ ПРОИЗВЕДЕНИЕ ПОЛОЖИТЕЛЬНЫХ ЧИСЕЛ ДАННОГО ОТРЕЗКА.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.