Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

Работа в Pascal.

10-11 класс

Составить программу, позволяющая по введенным координатам точки определить принадлежит ли она заштрихованной области или нет. пожалуйста укажите номер варианта которого вы сделали :)

Myyaarik 13 авг. 2014 г., 16:07:45 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Manuch77
13 авг. 2014 г., 17:07:20 (9 лет назад)

В9
Uses crt;
label tf, ft;
var u,i,j,k,k1,n, n1,x,y,z,g:integer; ax, ay:array[1..4] of integer; t1,t2, flag:Boolean;
begin
clrscr;
write('koordinat. XY '); readln(x,y);
case x of
0: x:=1;
1: x:=2;
2: x:=3;
3: x:=4;
end;
case y of
0: y:=1;
1: y:=2;
2: y:=3;
3: y:=4;
end;
k:=1;
for i:=1 to 4 do begin
    ax[i]:=k;
    inc(k);
end;
k1:=1;
for i:=1 to 4 do begin
    ay[i]:=k1;
    inc(k1);
end;
for i:=1 to 4 do begin
    if ax[i]=x then begin t1:=true; n:=ax[i]; break; end;
end;
if t1 = false then begin flag:=false; goto ft; end;
case n of
1: n1:=0;
2: n1:=1;
3: n1:=2;
4: n1:=3;
end;
case n1 of
0: goto tf;
1: begin
        for i:=1 to 4 do begin
            if ay[i]=y then begin t2:=true; flag:=true; y:=ay[i]; break; end;
        end;
    end;
2: begin
        for i:=1 to 4 do begin
            if ay[i]=y then begin t2:=true; flag:=true; y:=ay[i]; break; end;
        end;
    end;
3: goto tf;
end;

if t2 = false then begin flag:=false; goto ft; end;
{case y of
1: z:=0;
2: z:=1;
3: z:=2;
4: z:=3;
end;}
tf:
if ((n1=0) or (n1=3)) then begin if ((y=1) or (y=4)) then flag:=true; end
else flag:=false;

writeln;
ft:

writeln(flag);
readln
end.



Ответить

Другие вопросы из категории

Помогите пожалуйста ))СоставитьПомогите пожалуйста ))Составить программу по которой проверяют является ли элемент массива четным числом.Для записи

"делятся на"использовать стандартную функцию MOD,которая определяет остаток отделение числа А на число В.Примечание таблица R целочисленная.Построение блок-схемы,алгоритм и бейсики.Заранее большое спасибо))

Помогите пожалуйста)

Если можно то письменно)
заранее спасибо)

Читайте также

Написать программу чтоб работала в Pascal

запрашивает с клавиатуры два целых числа, их разность и частное (результат деления) и выводит на экран сообщение о правильности сделанных пользователем вычислений;

Напишите на языках Pascal и C++ программу, которая генерирует 2 случайных вещественных числа и вычисляет их сумму, разность, произведение и

частное. Напишите на языках Pascal и C++ программу, моделирующую выбор одной из костей домино ( в наборе 28 костей домино, каждая состоит из двух половин, на каждой половине – от 0 до 6 очков). С помощью этой программы ответьте на вопрос: какова вероятность того, что выпадет кость с числом очков, кратным 3

Написать программу проверки знания истории архитектуры. Программа должна вывести вопроси три варианта ответа. Пользователь должен выбрать

правильный ответ и ввести его номер.Ниже представлен рекомендуемый вид экрана во время работы программы (данные, введенные пользователем, выделены полужирным шрифтом).
Архитектор Исаакиевского собора:
1. Доменико Трезини
2. Огюст Монферран
3. Карл Росси
Введите номер правильного ответа и нажмите <Enter>
= 2
Правильно.
Архитектор Исаакиевского собора - Огюст Монферран

на языке Turbo Pascal

Написать программу в Pascal ABC чтобы полностью работала, которая ввод данных

в одномерный целочисленный массив осуществляет посредством цикла WHILE…DO, а вывод - REPEAT…UNTIL (в скобках указана размерность
массива).

Pascal составить прграмму .

Работа светофора запрограммирована таким образом : в начале каждого часа 3 минуты горит зелёный свет , затем 2 минуты красный , затем 3 минуты зелёный и т.д . Дано время t в минутах от начала часа . Определить сигнал какого цвета горит в этот момент времени для пешехода .



Вы находитесь на странице вопроса "Работа в Pascal.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.