Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 975 ответов!

В программе ПаскальАВС. Очень прошу помочь.

10-11 класс

В целочисленном массиве Х(-18; -25;
-13; 7; 9; -16; -4; 8; 1; -7; 2; 12; 15) Найти в исходном массиве количество нечетных элементов, имеющих четные
индексы. Найти первый положительный элемент, затем расставить элементы, стоящие
правее этого элемента в убывающем порядке.

Tamaz13 18 нояб. 2016 г., 9:45:53 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
CicTT
18 нояб. 2016 г., 10:34:07 (7 лет назад)

Вариант для ручного заполнения массива
var
   i, j, k, m, p: integer;
   x: array[1..13]of integer;
begin  
writeln('Вводите элементы массива по одному:');  
for i := 1 to 13 do
  begin
  readln(x[i]);
  write(x[i], ' ');
  if (i mod 2 = 0) and (x[i] mod 2 <> 0) then k := k + 1;
  if (x[i] > 0) and (m = 0) then m := i;
  end;
if m < 12 then m := m + 1;  
writeln;  
writeln('Количество искомых элементов: ', k);
for i := m to 13 do
    for j := m to 13 do
      if x[i] > x[j] then
        begin
        p := x[i];
        x[i] := x[j];
        x[j] := p;
        end;  
writeln('Измененный массив:');
for i := 1 to 13 do write(x[i], ' ');
end.

Вариант для работы только с заданными элементами массива:
var
   i, j, k, m, p: integer;
   x: array[1..13]of integer;
begin  
x[1]:=-18;
x[2]:=-25;
x[3]:=-13;
x[4]:=7;
x[5]:=9;
x[6]:=-16;
x[7]:=-4;
x[8]:=8;
x[9]:=1;
x[10]:=-7;
x[11]:=2;
x[12]:=12;
x[13]:=15;
writeln('Исходный массив:');  
for i := 1 to 13 do
  begin
  write(x[i], ' ');
  if (i mod 2 = 0) and (x[i] mod 2 <> 0) then k := k + 1;
  if (x[i] > 0) and (m = 0) then m := i;
  end;
if m < 12 then m := m + 1;  
writeln;  
writeln('Количество искомых элементов: ', k);
for i := m to 13 do
    for j := m to 13 do
      if x[i] > x[j] then
        begin
        p := x[i];
        x[i] := x[j];
        x[j] := p;
        end;  
writeln('Измененный массив:');
for i := 1 to 13 do write(x[i], ' ');
end.

Вариант для автоматического заполнения массива произвольными числами:
var
   i, j, k, m, p: integer;
   x: array[1..13]of integer;
begin 
writeln('Исходный массив:'); 
for i := 1 to 13 do
  begin
  x[i] := random(-10, 10);
  write(x[i], ' ');
  if (i mod 2 = 0) and (x[i] mod 2 <> 0) then k := k + 1;
  if (x[i] > 0) and (m = 0) then m := i;
  end;
if m < 12 then m := m + 1; 
writeln; 
writeln('Количество искомых элементов: ', k);
for i := m to 13 do
    for j := m to 13 do
      if x[i] > x[j] then
        begin
        p := x[i];
        x[i] := x[j];
        x[j] := p;
        end; 
writeln('Измененный массив:');
for i := 1 to 13 do write(x[i], ' ');
end.

+ 0 -
Io6673624настя
18 нояб. 2016 г., 12:28:26 (7 лет назад)

infor5, ты будешь решать, а то двойную работу делать?

+ 0 -
Лиза1177
18 нояб. 2016 г., 13:57:18 (7 лет назад)

Хорошо, решаю

Ответить

Другие вопросы из категории

Напишите программу, в которой бы пользователь мог ввести название города-юбиляра (N) и количество исполнившихся ему лет (Х). После нажатия кнопки ОК

должно выйти окно с поздравлением: “Поздравляем жителей города N с Х-летием!!!”.

нужно составить ФОРМУЛУ, которая поможет определить победителя. см. Вложения.

То есть нужно что бы у одного человека была самая большая сумма результатов и самый маленький вес, я так понимаю. По моим расчетам это Михальчук. Но в ответе В ЯЧЕЙКЕ должна появиться ФАМИЛИЯ. Не могу сделать( Хелп, ребят.
Это уже чистый Exel. Но я что то в его формулах вся заблудилась

известно количество страниц которые находит поисковый сервер по следующим запросам : собаки 200

кошки 250
кошки & собаки 50
Сколько страниц найдёт этот сервер по запросу
кошки или собаки ?

Читайте также

Очень вас прошу помочь написать программу.Написать программу-

1)с помощью генератора случайных чисел создать Н числа в диапазоне с [-50;50](длину массива Н надо ввести с клавиатуры)
2)надо вывести сделанный массив на экран
3)нужно вычислить и вывести,какое количество парных чисел
4)и вывести на экран все парные числа.
Очень вас прошу помогите,очень нужно до завтра сделать.Если можете помочь мне,пожалуйста помогите.

программирование циклов :

Составьте программу по которой компьютер десять раз запросит ввод целых чисел и в результате сообщит сколько среди введённых чисел чётных и сколько нечётных
помогите пожалуйста очень прошу )



Вы находитесь на странице вопроса "В программе ПаскальАВС. Очень прошу помочь.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.