Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

C++ цыклы while

10-11 класс

10. Дано целое число N (> 0). Используя операции деления нацело и взятия
остатка от деления, вывести все его цифры, начиная с самой правой
(разряда единиц).

ЛиЗа55 06 дек. 2016 г., 0:24:49 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Mariyamarkaryan
06 дек. 2016 г., 1:33:18 (7 лет назад)

Готово.................

Ответить

Другие вопросы из категории

В программе ПаскальАВС. Очень прошу помочь.

В целочисленном массиве Х(-18; -25;
-13; 7; 9; -16; -4; 8; 1; -7; 2; 12; 15) Найти в исходном массиве количество нечетных элементов, имеющих четные
индексы. Найти первый положительный элемент, затем расставить элементы, стоящие
правее этого элемента в убывающем порядке.

Напишите программу, в которой бы пользователь мог ввести название города-юбиляра (N) и количество исполнившихся ему лет (Х). После нажатия кнопки ОК

должно выйти окно с поздравлением: “Поздравляем жителей города N с Х-летием!!!”.

нужно составить ФОРМУЛУ, которая поможет определить победителя. см. Вложения.

То есть нужно что бы у одного человека была самая большая сумма результатов и самый маленький вес, я так понимаю. По моим расчетам это Михальчук. Но в ответе В ЯЧЕЙКЕ должна появиться ФАМИЛИЯ. Не могу сделать( Хелп, ребят.
Это уже чистый Exel. Но я что то в его формулах вся заблудилась

Читайте также

1)Найти сумму 1/2+1/4+1/6...1/20 на паскале с помощью while и точно такую же задачу с циклом for

2)Возведение степени a в степень n, с помощью while

Помогите с тестами по информатике!!! А1. Определите значение целочисленных переменных a и b после выполнения фрагмента программы:

a := 3 + 3*4;

b := (a div 10) + 4;

a := (b mod 10) + 2;

b:= a + b;

a:= a mod 2 + b div 3;

1) a=4, b=14;

2) a= 24, b= 6;

3) a=5, b=12;

4) a=8, b=12.

А2. Для какого из указанных значений числа X истинно высказывание

((X < 5)→(X < 3)) Ù ((X < 2)→(X < 1))

1) 1

2) 2

3) 3

4) 4

А3. Укажите, какое логическое выражение равносильно выражению ¬(A Ú ¬B Ú C) ?

1) ¬A Ú B Ú ¬C

2) A Ù ¬B Ù C

3) ¬A Ú ¬B Ú ¬C

4) ¬A Ù B Ù ¬C

X

Y

Z

F

1

1

1

1

1

1

0

1

1

0

1

1

А4. Символом F обозначено одно из указанных ниже логических выражений от трех аргументов: X, Y, Z. Дан фрагмент таблицы истинности выражения F (см. таблицу справа).

Какое выражение соответствует F?

1) X Ú ¬Y Ú Z

2) X Ù Y Ù Z

3) X Ù Y Ù ¬Z

4) ¬X Ú Y Ú ¬Z

А5. Что будет выведено на печать в результате выполнения следующих операторов:

a := 5; b := 10;

write( 'сумма двух чисел ' ); write( 'a+b' );

write( ' = ', a+b );

1) сумма двух чисел 5+10 = 15

2) сумма двух чисел a+b = 15

3) сумма двух чисел 5+10 = a+b

4) сумма двух чисел a+b = 5+10

5) ни один из ответов 1-4 не верен

А6. Чему было равно значение переменной a, если после выполнения операций

b := sqrt( sqr(a+1) );

c := -b;

a := 1 + 2 / (c-b);

она стала равна 0 ?

1) 2

2) 0

3) –1

4) любое вещ. число, не равное -1

5) ни один из ответов 1-4 не верен

А7. Чему будет равно значение А после выполнения цикла

а:=1024;

While a>0 do

a:=a / 2;

1) 0

2) 1

3) зациклится

4) 512

5) ни один из ответов 1-4 не верен

A8. Сколько раз выполнится тело цикла?

A:=32;

While A>2 do

Begin A:=A / 2; writeln(‘A’); end;

1) 8

2) 6

3) 5

4) 4

5) 3

1)Вычислить P=N!,где N вводится с клавиатуры с помощью трех видов цикла(1)repeat 2)while 3)For 2)модифицировать эти программы введя проверку N,если

N>7,то вывести фразу"превышение допустимых значений" В другом случае подсчитать N!



Вы находитесь на странице вопроса "C++ цыклы while", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.