Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 975 ответов!

какое значение будет храниться в переменной S после выполнения фрагмента программы:

10-11 класс

S:=2;
X:=0;
While x<5 do
begin
S:=S+X;
X:=X+2;
end;
с полным решением пожалуйста.. вроде 4 выходит,но не уверена

Katya512 08 нояб. 2014 г., 23:06:52 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Dikobrazz
09 нояб. 2014 г., 1:17:31 (9 лет назад)

Пока X<5
 1.S=2,x=2.
 2.s=4,x=4.
 3.s=8,x=6.
 4.x>5,конец Цикла.
Ответ:8.

Ответить

Другие вопросы из категории

сколько битов в 1килобайте
ПОМОГИТЕ!!!

Выполните сложение:
а)620,2+1453,3 в восьмиричной СС
б)348,1+234,4 в шестнадцатиричной СС
Выполните вычитание:
а)1100001010-10000011 в двоичной СС
б)1520,5-400,2 в восьмиричной СС
в)368,4-239,6 в шестнадцатиричной СС
Подробно пожалуйста!

Читайте также

Помогите с тестами по информатике!!! А1. Определите значение целочисленных переменных a и b после выполнения фрагмента программы:

a := 3 + 3*4;

b := (a div 10) + 4;

a := (b mod 10) + 2;

b:= a + b;

a:= a mod 2 + b div 3;

1) a=4, b=14;

2) a= 24, b= 6;

3) a=5, b=12;

4) a=8, b=12.

А2. Для какого из указанных значений числа X истинно высказывание

((X < 5)→(X < 3)) Ù ((X < 2)→(X < 1))

1) 1

2) 2

3) 3

4) 4

А3. Укажите, какое логическое выражение равносильно выражению ¬(A Ú ¬B Ú C) ?

1) ¬A Ú B Ú ¬C

2) A Ù ¬B Ù C

3) ¬A Ú ¬B Ú ¬C

4) ¬A Ù B Ù ¬C

X

Y

Z

F

1

1

1

1

1

1

0

1

1

0

1

1

А4. Символом F обозначено одно из указанных ниже логических выражений от трех аргументов: X, Y, Z. Дан фрагмент таблицы истинности выражения F (см. таблицу справа).

Какое выражение соответствует F?

1) X Ú ¬Y Ú Z

2) X Ù Y Ù Z

3) X Ù Y Ù ¬Z

4) ¬X Ú Y Ú ¬Z

А5. Что будет выведено на печать в результате выполнения следующих операторов:

a := 5; b := 10;

write( 'сумма двух чисел ' ); write( 'a+b' );

write( ' = ', a+b );

1) сумма двух чисел 5+10 = 15

2) сумма двух чисел a+b = 15

3) сумма двух чисел 5+10 = a+b

4) сумма двух чисел a+b = 5+10

5) ни один из ответов 1-4 не верен

А6. Чему было равно значение переменной a, если после выполнения операций

b := sqrt( sqr(a+1) );

c := -b;

a := 1 + 2 / (c-b);

она стала равна 0 ?

1) 2

2) 0

3) –1

4) любое вещ. число, не равное -1

5) ни один из ответов 1-4 не верен

А7. Чему будет равно значение А после выполнения цикла

а:=1024;

While a>0 do

a:=a / 2;

1) 0

2) 1

3) зациклится

4) 512

5) ни один из ответов 1-4 не верен

A8. Сколько раз выполнится тело цикла?

A:=32;

While A>2 do

Begin A:=A / 2; writeln(‘A’); end;

1) 8

2) 6

3) 5

4) 4

5) 3

1)Определите значение переменной c после выполнения следующего фрагмента программы:

a :=40 ;
b := 10;
a := - a / 2*b,;
if a > b then
c := b - a
else c := a - 2 * b

2)Определите значение переменной c после выполнения следующего фрагмента программы:
a := 5;
a := a + 6;
b := - a;
c := a - 2 * b

Какое

значение будет принимать переменная Х, после выполнения фрагмента программы:

f:=10; d:=10;

If
f>=d then x:=f else
x:=d



Вы находитесь на странице вопроса "какое значение будет храниться в переменной S после выполнения фрагмента программы:", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.