Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 971 ответов!

Задача Складіть програму обчислення суми всіх натуральних чисел від 1 до n. (Використовуйте формулу суми членів арифметичної

10-11 класс

прогресії).

Sn=(2a1+(n-1)d)n/2, де a1 - перший член послідовності, d - різниця.

ваня20000000000 04 нояб. 2015 г., 12:53:12 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Tayachiraeva
04 нояб. 2015 г., 14:33:26 (8 лет назад)

B C++

#include "stdafx.h"
#include "iostream"
using namespace std;

main()
    {  int d,k,n,i,s=6;
cout<<"vvedite n \n";
    cin>>n;
    cout<<1<<endl<<2<<endl<<3<<endl;
    k=5;
    while (k<=n)
       { for (d=2;d*d<=k && k%d!=0;d++)
     ;
    if(d*d>k)
     cout<<k<<endl;
    s=k+s;
     k=k+2;
       }

    cout<<"summa="<<s;
    getchar();
    getchar();
    return 0;
}



Ответить

Другие вопросы из категории

Помогите решить задачу в Кумире.

дано натуральное число, подсчитать сумму четных цифр в его десятичной записи

Пожалуйста.

Составьте программу и блок-схему
Турист за день прошел А км. До обеда он шел t часов и прошел 20 км. Еще t2 часа он шел после обеда. Когда скорость туриста была выше: до обеда или после обеда и на сколько?

Какие устройства состоит из двух основных частей: накопителя и схем управления?

1) Усилители

2) Счетчики

3) Мультиплексоры

4) Запоминающие устройства

Читайте также

У басейн наливається вода з N труб. Про кожну трубу відомо: скільки літрів води в хвилину наливається з труби в басейн, скільки хвилин була відкрита

труба.Складіть програму для визначення, скільки літрів водибуло налито в басйн.

Помогите пожалуйста. Нужно решить в паскале.

Дано масив А[1..n]. Скласти програму підрахунку суми всіх елементів, що знаходяться між елементами А[1] і А[n].



Вы находитесь на странице вопроса "Задача Складіть програму обчислення суми всіх натуральних чисел від 1 до n. (Використовуйте формулу суми членів арифметичної", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.