Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

напишите класс который принимает с клавиатуры целое число и выводит на экран его квадрат но только в случае,если введенное число отрицательно.В

10-11 класс

противном случае на экран выводится сообщение ошибка

Bms98 19 окт. 2016 г., 23:31:56 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
миха1234567890
20 окт. 2016 г., 1:05:37 (7 лет назад)

var a:integer;

begin

readln(a);

if (a<0) then a:=sqr(a);

writeln(a) else writeln('Error');

end.

+ 0 -
Trigonometriya
20 окт. 2016 г., 2:23:33 (7 лет назад)

type Cl = class
  a:integer;
  constructor Create(b:integer);
  procedure SetVal(b:integer);
  function GetVal:integer;
  procedure Sq;
end;

constructor Cl.Create(b:integer);
begin
  a := b;
end;

procedure Cl.SetVal(b:integer);
begin
  a := b;
end;

function Cl.GetVal:integer;
begin
  GetVal := a;
end;

procedure Cl.Sq;
begin
  if a < 0 then
    writeln('a ^ 2 = ', a * a)
  else
    writeln('Error');
end;


var
  Obj:Cl;
  a :integer;
begin
  write('a = ');
  readln(a);
  Obj := Cl.Create(a);
  Obj.Sq;
  Readln;
  Obj.Destroy;
end.

Ответить

Читайте также

Напишите программу, которая принимает с клавиатуры числа, пока не будет введено значение 999. Программа должна подсчитать, сколько значений было

введено с клавиатуры (не считая значения 999) и вывести эту информацию на экран.

Напишите программу, которая

позволяет ввести три вещественных числа и выводит на экран:


разность
целых частей первого и второго чисел;
косинус
удвоенного произведения первого на третье;
сумму
квадратов синуса второго числа и косинуса третьего.


Все вещественные числа должны
быть выведены в форме с фиксированной точкой с двумя знаками после запятой;
перед каждым вычисленным значением должны идти пояснительный текст и выражение.



Вы находитесь на странице вопроса "напишите класс который принимает с клавиатуры целое число и выводит на экран его квадрат но только в случае,если введенное число отрицательно.В", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.