Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

Дана матрица размерностью nxn найти

10-11 класс

Дана матрица размерностью nxn найти минимальный элемент среди элементов расположенных над главной диагональю матрицы. Найти квадрат разности среди арифметических значений элементов матрицы ,находящихся ниже и выше главной диагонали

Рождественская12 22 авг. 2013 г., 10:41:17 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Стася2012
22 авг. 2013 г., 11:59:13 (10 лет назад)

const n=3;
var a:array[1..n,1..n] of integer;
i,j,min,s:integer;
upsr,downsr,k:real;
begin
for i:=1 to n do
for j:=1 to n do a[i,j]:=random(10);
for i:=1 to n do begin
for j:=1 to n do write(a[i,j]:5);
writeln;
end;
min:=a[1,1];
s:=0;
for i:=1 to n do
for j:=1 to n do begin
if (a[i,j]<min) and (j>i) then min:=a[i,j];
end;
for i:=1 to n do
for j:=1 to n do
if i<j then s:=s+a[i,j]; upsr:=s/((sqr(n)-n)/2);
s:=0;
for i:=1 to n do
for j:=1 to n do
if i>j then s:=s+a[i,j];
downsr:=s/((sqr(n)-n)/2);
k:=sqr(downsr-upsr);
writeln('минимальный элемент выше главной диагонали ',min);
writeln('среднее арифметическое элементов выше главной диагонали ',upsr);
writeln('среднее арифметическое элементов ниже главной диагонали ',downsr);
writeln('квадрат разности средних арифметических значений элементов матрицы 

+ 0 -
Lbvf1996
22 авг. 2013 г., 13:09:32 (10 лет назад)

Второе условие не совсем понятно, которое про квадрат разности арифметических значений

+ 0 -
Selya555
22 авг. 2013 г., 15:18:25 (10 лет назад)

Все как дали тут написала. Если бы что-то понимала ,сюда не писала бы))

+ 0 -
Kate3886
22 авг. 2013 г., 16:20:19 (10 лет назад)

Тоже логично. Могу сделать первое условие, второе пока что не понимаю)

+ 0 -
Rada95
22 авг. 2013 г., 16:52:03 (10 лет назад)

Стоп, проверь в условии: Там вместо "среди" случаем не "средних арифметических значений"?

+ 0 -
Pharm69
22 авг. 2013 г., 18:03:15 (10 лет назад)

да-да!средних)прости пожалуйста фотка неочень

Ответить

Другие вопросы из категории

Помогите!!!!

Прошу помогите, умоляю.........
Это Паскаль.....

Написать программу на turbo pascal.

1.Вычислить значение факториала n! (P=1*2*...*n*N)..N=12
2.Найти сумму элементов заданного массива C[1..n]. Данные для ввода: n=7; C[1;2;3;-4;5;-6;7].
3.

Читайте также

1)Дана матрица размером M * N. В каждой строке матрицы найти минимальный элемент и максимальный из найденного.

2)дана матрица размерами N * N. Поменять местами столбец с максимальным и столбец содержащий минимальное количество нулевых элементов. Использовать три процедуры (заполнение, смена, вывод).

Дана матрица размерностью n*m.

найти в каждой строке max и min элемент

Написать программу для паскаля. Дана квадратная матрица

порядка n(n=5).
Если в данной матрице a нет отрицательных элементов,
то транспонировать её, иначе выдать сообщение.

Задачи паскаль, помогите пожалуйста кто. 1, Напишите программу, реализующую следующие вычисления. Дан номер месяца — целое число в диапазоне

1–12, введенное с клавиатуры (1 — январь, 2 — февраль и т. д.). Вывести название соответствующего времени года («зима», «весна», «лето», «осень»).

2, Напишите программу, реализующую следующие вычисления. Дана матрица размера M x N (числа вводятся с клавиатуры). Для каждого столбца матрицы найти произведение его элементов. Полученные значения вывести в текстовый файл.

3, Напишите программу с использованием функции CircleS(R) вещественного типа, находящей площадь круга радиуса R (R — вещественное). С помощью этой функции найти площади трех кругов с данными радиусами. Площадь круга радиуса R вычисляется по формуле S = πR2.

4, Напишите программу, реализующую следующие вычисления. Дано целое число N (1≤N≤26), введенное с клавиатуры. Вывести N первых прописных (то есть заглавных) букв латинского алфавита.



Вы находитесь на странице вопроса "Дана матрица размерностью nxn найти", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.