Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Даны действительные положительные числа a, b, c, которые являются длинами сторон треугольника. Напишите программу позволяющую найти радиус вписанной и

5-9 класс

описанной окружности

Dementushkamrmr 07 февр. 2014 г., 20:08:22 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Trikotana
07 февр. 2014 г., 21:08:56 (10 лет назад)

var
a,b,c,p,r1,r2:real;
begin
readln(a,b,c);
p:=(a+b+c)/2;
r1 := (a*b*c)/(4*sqrt(p*(p-a)*(p-b)*(p-c)));// описанная
r2 := sqrt(((p-a)*(p-b)*(p-c))/p);//вписанная
writeln(r1:1:5,' ',r2:1:5);
readln;
readln
end.

Ответить

Читайте также

Паскаль напишите пожалуйста программу Срочно, прошу!!! Даны действительные положительные числа a, b, c, которые задают длины сторон треугольника

и угол между ними. Напишите программу, позволяющую найти длину третьей стороны и два остальных угла.

Даны три произвольных числа a,b,c, значение которых задают длины сторон треугольника. Выведите 0,если нельзя построить треугольник с такими длинами

сторон; 3,если получается равностороний треугольник; 2 равнобедренный; 1 в остальных случаях. Задача в Паскале!!!

Паскаль

Дан массив, содержащий 70 неотрицательных целых чисел. Напишите программу, позволяющую найти и вывести наименьшую чётную сумму двух соседних элементов массива. Гарантируется, что в массиве есть соседние элементы с чётной суммой.



Вы находитесь на странице вопроса "Даны действительные положительные числа a, b, c, которые являются длинами сторон треугольника. Напишите программу позволяющую найти радиус вписанной и", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.