Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

Простейшая программа в Pascal.

10-11 класс

Напишите программу по нахождению расстояния между двумя точками.

Sevka1996 12 окт. 2016 г., 13:17:44 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Pkhilton
12 окт. 2016 г., 15:02:34 (7 лет назад)

uses crt;
var x1,y1,x2,y2:integer;
dlina:real;
begin
read(x1,y1);
read(x2,y2);
dlina:=sqrt(sqr(x2-x1)+sqr(y2-y1));
writeln(dlina);
end.

Ответить

Другие вопросы из категории

Всё надо сделать на паскале.

a) x^5 b)x^6 c)x^8 d)x^9 e)x^10
2 задание:
Дан диаметр окружности d. Найти его длину (L=П*d)
3 задание:
Найти длину окружности L и площадь круга S заданного радиуса R: L=2πR, S = πR^2
4 задание:
Даны 2 числа a и b. Найти их среднее арифметическое
5 задание:
Даны 2 неотрицательных числа a и b. Найти их среднее геометрическое (квадратный корень из их произведения)
6 задание:
Найти расстояние между двумя точками с заданными координатами x1 и x2 на числовой оси: |x2 - x1|.
Буду очень благодарен.

Читайте также

Помогите пожалуйста!! ) составить программу в "Pascal abc"!!)

Составить программу вычисления значений функции F(x) на отрезке [а; b] с шагом h.
Результат представить в виде таблицы, первый столбец которой — значения
аргумента, второй — соответствующие значения функции: "F(x) = 1/2 ctg x/4+4"

Написать программу в Pascal, используя массивы.

Дано массив А[1..n]. Сделать программу которая выводит те элементы массива? индексы которых являются степени двойки
Желательно с обьяснением строк

Помогите написать код программы в Pascal для задачи:

дано натуральное число n среди чисел 1,2 ... n найти все те, которые можно представить в виде суммы квадратов двух натуральных чисел.
Заранее огромное спасибо!!

ПОМОГИТЕ НАПИСАТЬ ПРОГРАММУ В PASCAL! ПОЖАЛУЙСТА!

Дан массив X(N,M). Если первый элемент массива положительный, то найти сумму элементов среди элементов четных строк массива, иначе произведение.

От прямоугольника 324х141 отрезают квадраты со

стороной 141, пока это возможно. Затем вновь отрезают квадраты со стороной,
равной 324-2*141=42 и т.д. На какие квадраты и насколько будет разделен прямоугольник?
Решение программы в Pascal ABC



Вы находитесь на странице вопроса "Простейшая программа в Pascal.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.